aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-04-25 15:59:23 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-05-30 22:47:14 +0100
commite0c75841078bf65905c1c9aa2946241b2474a7e2 (patch)
tree615c7fc980a71e0c1f4309300b7859714e078089
parent3891fcec863602a0ae6d0f3d305ea50a79a205d9 (diff)
downloadopenembedded-core-contrib-e0c75841078bf65905c1c9aa2946241b2474a7e2.tar.gz
default-versions.inc: drop python-related defaults
There is only one version of python 2.x provided, so no need to set a preferred version. PYTHON_BASEVERSION is now set explicitly in python-dir.bbclass and python3-dir.bbclass, so fix up a few recipes that relied on it being set in default-versions.inc without inheriting python-dir. Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
-rw-r--r--meta/conf/distro/include/default-versions.inc5
-rw-r--r--meta/recipes-devtools/rpm/rpm_5.4+cvs.bb2
-rw-r--r--meta/recipes-devtools/rpm/rpm_5.4.16.bb2
-rw-r--r--meta/recipes-kernel/lttng/lttng-tools_git.bb2
-rw-r--r--meta/recipes-rt/rt-tests/hwlatdetect_0.96.bb1
5 files changed, 4 insertions, 8 deletions
diff --git a/meta/conf/distro/include/default-versions.inc b/meta/conf/distro/include/default-versions.inc
index a04ea718bd..cc8c533d4c 100644
--- a/meta/conf/distro/include/default-versions.inc
+++ b/meta/conf/distro/include/default-versions.inc
@@ -2,11 +2,6 @@
# Default preferred versions
#
-# Force the python versions in one place
-PYTHON_BASEVERSION ?= "2.7"
-PREFERRED_VERSION_python ?= "2.7.11"
-PREFERRED_VERSION_python-native ?= "2.7.11"
-
# Force the older version of liberation-fonts until we fix the fontforge issue
PREFERRED_VERSION_liberation-fonts ?= "1.04"
diff --git a/meta/recipes-devtools/rpm/rpm_5.4+cvs.bb b/meta/recipes-devtools/rpm/rpm_5.4+cvs.bb
index 0991f6d52a..625d75e825 100644
--- a/meta/recipes-devtools/rpm/rpm_5.4+cvs.bb
+++ b/meta/recipes-devtools/rpm/rpm_5.4+cvs.bb
@@ -156,7 +156,7 @@ SRC_URI_append_libc-musl = "\
# to process certain package feeds.
#SRC_URI += "file://rpm-debug-platform.patch"
-inherit autotools gettext
+inherit autotools gettext python-dir
acpaths = "-I ${S}/db/dist/aclocal -I ${S}/db/dist/aclocal_java"
diff --git a/meta/recipes-devtools/rpm/rpm_5.4.16.bb b/meta/recipes-devtools/rpm/rpm_5.4.16.bb
index 7ebd5e9359..3adb29c347 100644
--- a/meta/recipes-devtools/rpm/rpm_5.4.16.bb
+++ b/meta/recipes-devtools/rpm/rpm_5.4.16.bb
@@ -165,7 +165,7 @@ SRC_URI_append_libc-musl = "\
UPSTREAM_CHECK_REGEX = "rpm-(?P<pver>(\d+[\.\-_]*)+)-.*$"
-inherit autotools gettext
+inherit autotools gettext python-dir
acpaths = "-I ${S}/db/dist/aclocal -I ${S}/db/dist/aclocal_java"
diff --git a/meta/recipes-kernel/lttng/lttng-tools_git.bb b/meta/recipes-kernel/lttng/lttng-tools_git.bb
index 3ce4a9ee17..8ef267c833 100644
--- a/meta/recipes-kernel/lttng/lttng-tools_git.bb
+++ b/meta/recipes-kernel/lttng/lttng-tools_git.bb
@@ -35,7 +35,7 @@ SRC_URI = "git://git.lttng.org/lttng-tools.git;branch=stable-2.7 \
S = "${WORKDIR}/git"
-inherit autotools-brokensep ptest pkgconfig useradd
+inherit autotools-brokensep ptest pkgconfig useradd python-dir
USERADD_PACKAGES = "${PN}"
GROUPADD_PARAM_${PN} = "tracing"
diff --git a/meta/recipes-rt/rt-tests/hwlatdetect_0.96.bb b/meta/recipes-rt/rt-tests/hwlatdetect_0.96.bb
index 962069e3dc..025eb63232 100644
--- a/meta/recipes-rt/rt-tests/hwlatdetect_0.96.bb
+++ b/meta/recipes-rt/rt-tests/hwlatdetect_0.96.bb
@@ -6,6 +6,7 @@ LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
require rt-tests.inc
+inherit python-dir
EXTRA_OEMAKE += "PYLIB=${libdir}/python${PYTHON_BASEVERSION}/dist-packages"