aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2016-05-11 16:36:37 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-06-01 08:04:11 +0100
commit72be3752a56d681672fb3e04413ff3cc59391150 (patch)
tree76b81efa64b9c80202e06437515386127e1092b5
parenta5aa15188b0c43432251039adc82c6c5cc453b2e (diff)
downloadopenembedded-core-contrib-72be3752a56d681672fb3e04413ff3cc59391150.tar.gz
python3-mako: add a Python 3 recipe
This will be necessary for transiting piglit to Python 3. Python 2 recipe should be kept as it is used by mesa (and gobject-introspection, for now). Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
-rw-r--r--meta/recipes-devtools/python/python-mako_1.0.3.bb6
-rw-r--r--meta/recipes-devtools/python/python3-mako_1.0.3.bb24
2 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-mako_1.0.3.bb b/meta/recipes-devtools/python/python-mako_1.0.3.bb
index 9efd700dc0..d4f426dadd 100644
--- a/meta/recipes-devtools/python/python-mako_1.0.3.bb
+++ b/meta/recipes-devtools/python/python-mako_1.0.3.bb
@@ -22,3 +22,9 @@ RDEPENDS_${PN} = "python-threading \
RDEPENDS_${PN}_class-native = ""
BBCLASSEXTEND = "native nativesdk"
+
+# The same utility is packaged in python3-mako, so it would conflict
+do_install_append() {
+ rm -f ${D}${bindir}/mako-render
+ rm -df ${D}${bindir}
+}
diff --git a/meta/recipes-devtools/python/python3-mako_1.0.3.bb b/meta/recipes-devtools/python/python3-mako_1.0.3.bb
new file mode 100644
index 0000000000..c77060357d
--- /dev/null
+++ b/meta/recipes-devtools/python/python3-mako_1.0.3.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Templating library for Python"
+SECTION = "devel/python"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=deb3ff8e4c17aaf7b80889b6b2bf4c83"
+
+SRC_URI = "https://pypi.python.org/packages/source/M/Mako/Mako-${PV}.tar.gz"
+
+SRC_URI[md5sum] = "a78f20f6366a8a0659ce5532f8614e53"
+SRC_URI[sha256sum] = "7644bc0ee35965d2e146dde31827b8982ed70a58281085fac42869a09764d38c"
+
+UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/mako/"
+UPSTREAM_CHECK_REGEX = "/Mako/(?P<pver>(\d+[\.\-_]*)+)"
+
+S = "${WORKDIR}/Mako-${PV}"
+
+inherit setuptools3
+
+RDEPENDS_${PN} = "python3-threading \
+ python3-netclient \
+ python3-html \
+"
+RDEPENDS_${PN}_class-native = ""
+
+BBCLASSEXTEND = "native nativesdk"