aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Oberritter <obi@opendreambox.org>2016-04-22 02:09:20 +0200
committerAndreas Oberritter <obi@opendreambox.org>2018-05-07 23:25:22 +0200
commitd3ee025f3541c02819aa6cca2a7e599616374eb4 (patch)
tree81c8bf7b887edf1abe4574525aa9661d03d8e897
parent16e3458b45aa1a39fbc0b43b95fae95908d15991 (diff)
downloadopenembedded-core-contrib-d3ee025f3541c02819aa6cca2a7e599616374eb4.tar.gz
apt: more fine-grained packaging
Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
-rw-r--r--meta/recipes-devtools/apt/apt_1.2.12.bb9
1 files changed, 7 insertions, 2 deletions
diff --git a/meta/recipes-devtools/apt/apt_1.2.12.bb b/meta/recipes-devtools/apt/apt_1.2.12.bb
index a233a98f77..64fd4e2a04 100644
--- a/meta/recipes-devtools/apt/apt_1.2.12.bb
+++ b/meta/recipes-devtools/apt/apt_1.2.12.bb
@@ -117,13 +117,18 @@ do_install_append_class-target() {
echo 'APT::Architecture "${DPKG_ARCH}";' > ${D}${sysconfdir}/apt/apt.conf
}
-PACKAGES =+ "${PN}-utils"
+PACKAGES =+ "${PN}-dselect ${PN}-transport-https ${PN}-utils lib${PN}-inst lib${PN}-pkg"
-RDEPENDS_${PN} = "dpkg bash debianutils"
+RDEPENDS_${PN} = "dpkg debianutils"
+RDEPENDS_${PN}-dselect = "bash"
FILES_${PN} += "${libdir}/dpkg ${systemd_system_unitdir}/apt-daily.service"
+FILES_${PN}-dselect = "${libdir}/dpkg/methods/apt"
+FILES_${PN}-transport-https = "${libdir}/apt/methods/https"
FILES_${PN}-utils = "${bindir}/apt-extracttemplates \
${bindir}/apt-ftparchive \
${bindir}/apt-sortpkgs"
+FILES_lib${PN}-inst = "${libdir}/libapt-inst${SOLIBS}"
+FILES_lib${PN}-pkg = "${libdir}/libapt-pkg${SOLIBS}"
BBCLASSEXTEND = "native"