aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDennis Lan <dennis.yxun@gmail.com>2012-07-03 07:03:46 +0000
committerAndreas Oberritter <obi@opendreambox.org>2012-12-12 00:14:53 +0100
commita6435c93a0c8e1b893dc4b7296157fbda61c2e39 (patch)
tree3ab67c421f1b57f4bcb4eb334b02a8aedced2902
parentce5a1856e862ab19cbab125d18ccd76d34b5a7d0 (diff)
downloadopenembedded-core-contrib-a6435c93a0c8e1b893dc4b7296157fbda61c2e39.tar.gz
openjade-native: fix undefined Getopts error, use std namespace
Using Gentoo Linux as the build host, it fails without this patch Use Getopt::Std in place of getopts.pl. https://bugs.gentoo.org/show_bug.cgi?id=420083 which following error: /usr/bin/perl -w ./../msggen.pl -l jstyleModule InterpreterMessages.msg /usr/bin/perl -w ./../msggen.pl -l jstyleModule DssslAppMessages.msg Undefined subroutine &main::Getopts called at ./../msggen.pl line 22. make[2]: *** [InterpreterMessages.h] Error 2 make[2]: *** Waiting for unfinished jobs.... Undefined subroutine &main::Getopts called at ./../msggen.pl line 22. make[2]: *** [DssslAppMessages.h] Error 2 Signed-off-by: Dennis Lan <dennis.yxun@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/openjade/openjade-1.3.2/msggen.pl.patch44
-rw-r--r--meta/recipes-devtools/openjade/openjade-native_1.3.2.bb3
2 files changed, 46 insertions, 1 deletions
diff --git a/meta/recipes-devtools/openjade/openjade-1.3.2/msggen.pl.patch b/meta/recipes-devtools/openjade/openjade-1.3.2/msggen.pl.patch
new file mode 100644
index 0000000000..b47fd4655f
--- /dev/null
+++ b/meta/recipes-devtools/openjade/openjade-1.3.2/msggen.pl.patch
@@ -0,0 +1,44 @@
+commit fcc5b94f118495b1a467edcda6c6f631691c3f69
+Author: Dennis Lan <dennis.yxun@gmail.com>
+Date: Tue Jul 3 09:25:42 2012 +0800
+
+ openjade: fix undefined Getopts error, use std namespace
+
+ Using Gentoo Linux as the build host, it fails without this patch
+ Use Getopt::Std in place of getopts.pl.
+
+ Upstream-Status: Inappropriate [no upstream]
+ Original-Author-By: Mike Gilbert <floppym@gentoo.org>
+ Signed-off-by: Dennis Lan <dennis.yxun@gmail.com>
+
+diff --git a/msggen.pl b/msggen.pl
+index 0c33968..2ee3f66 100644
+--- a/msggen.pl
++++ b/msggen.pl
+@@ -4,6 +4,7 @@
+ # See the file COPYING for copying permission.
+
+ use POSIX;
++use Getopt::Std;
+
+ # Package and version.
+ $package = 'openjade';
+@@ -18,8 +19,7 @@ $gen_c = 0;
+ undef $opt_l;
+ undef $opt_p;
+ undef $opt_t;
+-do 'getopts.pl';
+-&Getopts('l:p:t:');
++getopts('l:p:t:');
+ $module = $opt_l;
+ $pot_file = $opt_p;
+
+@@ -72,7 +72,7 @@ while (<DEF>) {
+ else {
+ $field[0] =~ /^[IWQXE][0-9]$/ || &error("invalid first field");;
+ $type[$num] = substr($field[0], 0, 1);
+- $argc = int(substr($field[0], 1, 1));
++ $argc = substr($field[0], 1, 1);
+ }
+ $nargs[$num] = $argc;
+ $field[1] =~ /^[a-zA-Z_][a-zA-Z0-9_]+$/ || &error("invalid tag");
diff --git a/meta/recipes-devtools/openjade/openjade-native_1.3.2.bb b/meta/recipes-devtools/openjade/openjade-native_1.3.2.bb
index 5b29c1fda0..a539c353a0 100644
--- a/meta/recipes-devtools/openjade/openjade-native_1.3.2.bb
+++ b/meta/recipes-devtools/openjade/openjade-native_1.3.2.bb
@@ -7,13 +7,14 @@ SECTION = "base"
LICENSE = "BSD"
LIC_FILES_CHKSUM = "file://COPYING;md5=641ff1e4511f0a87044ad42f87cb1045"
-PR = "r4"
+PR = "r5"
DEPENDS = "opensp-native sgml-common-native"
RDEPENDS_${PN} = "sgml-common-native"
SRC_URI = "${SOURCEFORGE_MIRROR}/openjade/openjade-${PV}.tar.gz \
file://makefile.patch \
+ file://msggen.pl.patch \
file://reautoconf.patch \
file://user-declared-default-constructor.patch"