summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kanavin <alexander.kanavin@linux.intel.com>2017-06-16 14:38:58 +0300
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-06-28 15:51:55 +0100
commitfc318fb191b68232cc400db2d5eb543d296ee884 (patch)
tree0b02aa9e2421be3cf00fe56198d6916fa39c3317
parent2ad6c563828e70728eb48095b2326b52342df37c (diff)
downloadopenembedded-core-contrib-fc318fb191b68232cc400db2d5eb543d296ee884.tar.gz
gnomebase.bbclass: add datadir/icons and datadir/appdata to standard FILES list
Gnome apps seem to increasingly package those, so let's make it common. Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
-rw-r--r--meta/classes/gnomebase.bbclass2
-rw-r--r--meta/recipes-gnome/epiphany/epiphany_3.22.6.bb2
-rw-r--r--meta/recipes-kernel/sysprof/sysprof_3.24.1.bb1
3 files changed, 3 insertions, 2 deletions
diff --git a/meta/classes/gnomebase.bbclass b/meta/classes/gnomebase.bbclass
index 54aa45f174..4ccc8e0781 100644
--- a/meta/classes/gnomebase.bbclass
+++ b/meta/classes/gnomebase.bbclass
@@ -14,6 +14,8 @@ FILES_${PN} += "${datadir}/application-registry \
${datadir}/polkit* \
${datadir}/GConf \
${datadir}/glib-2.0/schemas \
+ ${datadir}/appdata \
+ ${datadir}/icons \
"
FILES_${PN}-doc += "${datadir}/devhelp"
diff --git a/meta/recipes-gnome/epiphany/epiphany_3.22.6.bb b/meta/recipes-gnome/epiphany/epiphany_3.22.6.bb
index 651fef1bf0..e9e3493e67 100644
--- a/meta/recipes-gnome/epiphany/epiphany_3.22.6.bb
+++ b/meta/recipes-gnome/epiphany/epiphany_3.22.6.bb
@@ -19,5 +19,5 @@ do_configure_prepend() {
sed -i -e s:help::g ${S}/Makefile.am
}
-FILES_${PN} += "${datadir}/appdata ${datadir}/dbus-1 ${datadir}/gnome-shell/search-providers"
+FILES_${PN} += "${datadir}/dbus-1 ${datadir}/gnome-shell/search-providers"
RDEPENDS_${PN} = "iso-codes adwaita-icon-theme"
diff --git a/meta/recipes-kernel/sysprof/sysprof_3.24.1.bb b/meta/recipes-kernel/sysprof/sysprof_3.24.1.bb
index ca3589bcc9..36093ca89f 100644
--- a/meta/recipes-kernel/sysprof/sysprof_3.24.1.bb
+++ b/meta/recipes-kernel/sysprof/sysprof_3.24.1.bb
@@ -30,7 +30,6 @@ PACKAGECONFIG[polkit] = "--enable-polkit,--disable-polkit,polkit dbus"
SOLIBS = ".so"
FILES_SOLIBSDEV = ""
-FILES_${PN} += "${datadir}/icons/ ${datadir}/appdata"
SYSTEMD_SERVICE_${PN} = "${@bb.utils.contains('PACKAGECONFIG', 'polkit', 'sysprof2.service', '', d)}"