summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel McGregor <daniel.mcgregor@vecima.com>2020-01-23 15:44:41 -0600
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-02-04 15:56:24 +0000
commit54a5daca450b8be251c45730ae4c0511811b668a (patch)
treea8ab82ae967163c641011bbccf0a9add76e45540
parent009dbec9058bf43e63eeabdd24ecad990bf22568 (diff)
downloadopenembedded-core-contrib-54a5daca450b8be251c45730ae4c0511811b668a.tar.gz
procps: enable optional systemd support
procps includes support for listing the owning unit of a process, but this support is disabled by default. Enable support using a PACKAGECONFIG that depends on the systemd DISTRO_FEATURE. Signed-off-by: Daniel McGregor <daniel.mcgregor@vecima.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-extended/procps/procps_3.3.15.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-extended/procps/procps_3.3.15.bb b/meta/recipes-extended/procps/procps_3.3.15.bb
index f240e54fd8..17abd96dca 100644
--- a/meta/recipes-extended/procps/procps_3.3.15.bb
+++ b/meta/recipes-extended/procps/procps_3.3.15.bb
@@ -24,6 +24,9 @@ S = "${WORKDIR}/procps-ng-${PV}"
EXTRA_OECONF = "--enable-skill --disable-modern-top"
+PACKAGECONFIG ??= "${@bb.utils.filter('DISTRO_FEATURES', 'systemd', d)}"
+PACKAGECONFIG[systemd] = "--with-systemd,--without-systemd,systemd"
+
do_install_append () {
install -d ${D}${base_bindir}
[ "${bindir}" != "${base_bindir}" ] && for i in ${base_bindir_progs}; do mv ${D}${bindir}/$i ${D}${base_bindir}/$i; done