summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2017-11-15 13:57:29 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-01-18 13:05:47 +0000
commit594ced59dc80c11d573ae4a16e1aff910a8d9300 (patch)
tree965538bf224bbe439480431ac3565c5328c6a15b
parent11245b435230808e899e475e620b25b44599cd06 (diff)
downloadopenembedded-core-contrib-594ced59dc80c11d573ae4a16e1aff910a8d9300.tar.gz
contrib/yocto-bsp-kernel-update.sh: remove this script
This script was unused since yocto-bsp tool had been removed. Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rwxr-xr-xscripts/contrib/yocto-bsp-kernel-update.sh60
1 files changed, 0 insertions, 60 deletions
diff --git a/scripts/contrib/yocto-bsp-kernel-update.sh b/scripts/contrib/yocto-bsp-kernel-update.sh
deleted file mode 100755
index b3aa705603..0000000000
--- a/scripts/contrib/yocto-bsp-kernel-update.sh
+++ /dev/null
@@ -1,60 +0,0 @@
-#!/bin/sh
-#
-# Copyright (c) 2017, Intel Corporation.
-# All rights reserved.
-#
-# This program is free software; you can redistribute it and/or modify
-# it under the terms of the GNU General Public License as published by
-# the Free Software Foundation; either version 2 of the License, or
-# (at your option) any later version.
-#
-# This program is distributed in the hope that it will be useful,
-# but WITHOUT ANY WARRANTY; without even the implied warranty of
-# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See
-# the GNU General Public License for more details.
-#
-# You should have received a copy of the GNU General Public License
-# along with this program; if not, write to the Free Software
-# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
-#
-# Description: creates a new set of kernel templates based on version
-#
-
-set -o nounset
-set -o errexit
-
-if [ $# -ne 4 ]; then
- cat << EOF
-usage: $0 from_mayor from_minor to_mayor to_minor
-EOF
- exit 1
-else
- fma=$1 # from mayor
- fmi=$2 # from minor
- tma=$3 # to mayor
- tmi=$4 # to minor
-fi
-
-poky=$(readlink -e $(dirname $(dirname $(dirname $0))))
-arch=$poky/scripts/lib/bsp/substrate/target/arch
-
-
-# copy/rename templates
-for from in $(ls -1 $arch/*/recipes-kernel/linux/linux-yocto*_$fma\.$fmi.bbappend)
-do
- to=$(echo $from | sed s/$fma\.$fmi/$tma\.$tmi/)
- cp $from $to
-done
-
-# replace versions string inside new templates
-for bbappend in $(ls -1 $arch/*/recipes-kernel/linux/linux-yocto*_$tma\.$tmi.bbappend)
-do
- sed -i 1s/$fma\.$fmi/$tma\.$tmi/ $bbappend
- sed -i \$s/$fma\.$fmi/$tma\.$tmi/ $bbappend
-done
-
-# update the noinstall files
-for noinstall in $(ls -1 $arch/*/recipes-kernel/linux/kernel-list.noinstall)
-do
- sed -i s/$fma\.$fmi/$tma\.$tmi/g $noinstall;
-done