aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGernot Hillier <gernot.hillier@siemens.com>2017-04-26 12:57:44 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-05-10 12:21:34 +0100
commit60c9b55d2247ca4a5074804eb42189c31d33fcf8 (patch)
tree6f086066c9cee6e3588fd8413f7a8953415075c8
parent43f7652baa0f1973477731ce05786eda2cc81c09 (diff)
downloadopenembedded-core-contrib-60c9b55d2247ca4a5074804eb42189c31d33fcf8.tar.gz
tcf-agent: fix machine setting for arm64 build
tcf-agent uses "a64", not "aarch64", see agent/Makefile.inc. This fix allows to re-enable features like SERVICE_Breakpoints and SERVICE_ MemoryMap on arm64. Signed-off-by: Gernot Hillier <gernot.hillier@siemens.com> Acked-by: Eugene Tarassov <eugene.tarassov@xilinx.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/tcf-agent/tcf-agent_git.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/tcf-agent/tcf-agent_git.bb b/meta/recipes-devtools/tcf-agent/tcf-agent_git.bb
index e5e41f148e..cd0081ac16 100644
--- a/meta/recipes-devtools/tcf-agent/tcf-agent_git.bb
+++ b/meta/recipes-devtools/tcf-agent/tcf-agent_git.bb
@@ -30,7 +30,7 @@ INITSCRIPT_NAME = "tcf-agent"
INITSCRIPT_PARAMS = "start 99 3 5 . stop 20 0 1 2 6 ."
# mangling needed for make
-MAKE_ARCH = "`echo ${TARGET_ARCH} | sed s,i.86,i686,`"
+MAKE_ARCH = "`echo ${TARGET_ARCH} | sed s,i.86,i686, | sed s,aarch64,a64,`"
MAKE_OS = "`echo ${TARGET_OS} | sed s,^linux.*,GNU/Linux,`"
EXTRA_OEMAKE = "MACHINE=${MAKE_ARCH} OPSYS=${MAKE_OS} 'CC=${CC}' 'AR=${AR}'"