aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Ohly <patrick.ohly@intel.com>2017-03-30 17:09:36 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-03-30 22:52:32 +0100
commit508163bef169cf0d9aa97e73c02d1ecc68480e91 (patch)
treeef56ec07397993b927cec3368aa6c15dbad69dc2
parent7f40c934c3aeb1d34f95f30b281e25a17c428fce (diff)
downloadopenembedded-core-contrib-508163bef169cf0d9aa97e73c02d1ecc68480e91.tar.gz
net-tools: enable native and nativesdk variant
net-tools-native is needed by swtpm-wrappers (in meta-security) because swtpm_setup.sh calls netstat, which cannot be assumed to be present in all Linux installations (for example, it is not in OpenSUSE minimal base). Signed-off-by: Patrick Ohly <patrick.ohly@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-extended/net-tools/net-tools_1.60-26.bb11
1 files changed, 11 insertions, 0 deletions
diff --git a/meta/recipes-extended/net-tools/net-tools_1.60-26.bb b/meta/recipes-extended/net-tools/net-tools_1.60-26.bb
index be267351e3..115b3987c3 100644
--- a/meta/recipes-extended/net-tools/net-tools_1.60-26.bb
+++ b/meta/recipes-extended/net-tools/net-tools_1.60-26.bb
@@ -70,11 +70,21 @@ python do_patch() {
bb.build.exec_func('patch_do_patch', d)
}
+# i18n only enabled for the target, doesn't build for native
+# and isn't needed there.
+disable_i18n() {
+ sed -i -e 's/^I18N=1/# I18N=1/' ${S}/config.make
+}
+disable_i18n_class-target () {
+ :
+}
+
do_configure() {
# net-tools has its own config mechanism requiring "make config"
# we pre-generate desired options and copy to source directory instead
cp ${WORKDIR}/net-tools-config.h ${S}/config.h
cp ${WORKDIR}/net-tools-config.make ${S}/config.make
+ disable_i18n
}
do_compile() {
@@ -125,3 +135,4 @@ python __anonymous() {
}
ALTERNATIVE_PRIORITY = "100"
+BBCLASSEXTEND = "native nativesdk"