summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrei Gherzan <andrei@gherzan.ro>2019-05-30 13:22:23 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-05-31 15:36:20 +0100
commit024825532e9a855403cd0d2b08d8d9da4b9f0f5e (patch)
tree3faf1a248fd758e3907dc9c3a505a42fc850ddee
parent600a615042f19bfc99ce6f60515f9a61a20ca1c5 (diff)
downloadopenembedded-core-contrib-024825532e9a855403cd0d2b08d8d9da4b9f0f5e.tar.gz
ca-certificates: Fix openssl runtime dependencies
Since yocto thud, and more specifically since poky switched to openssl 1.1 line, the openssl binary is provided by 'openssl-bin'. This impacts the native and nativesdk recipe variants as well. (From OE-Core rev: dc778c70449ee5401b5a24ad18b22b88338c47c5) Signed-off-by: Andrei Gherzan <andrei@gherzan.ro> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-support/ca-certificates/ca-certificates_20190110.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/recipes-support/ca-certificates/ca-certificates_20190110.bb b/meta/recipes-support/ca-certificates/ca-certificates_20190110.bb
index 4c0425302f..efd9eaa71e 100644
--- a/meta/recipes-support/ca-certificates/ca-certificates_20190110.bb
+++ b/meta/recipes-support/ca-certificates/ca-certificates_20190110.bb
@@ -82,6 +82,8 @@ do_install_append_class-native () {
SYSROOT="${D}${base_prefix}" ${D}${sbindir}/update-ca-certificates
}
-RDEPENDS_${PN} += "openssl"
+RDEPENDS_${PN}_class-target = "openssl-bin"
+RDEPENDS_${PN}_class-native = "openssl-native"
+RDEPENDS_${PN}_class-nativesdk = "nativesdk-openssl-bin"
BBCLASSEXTEND = "native nativesdk"