summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2019-06-11 11:10:40 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-06-12 10:54:39 +0100
commit0191f500c5b661652d0387c99ba6262979c08293 (patch)
treeeedb9c56833bc0072274a27fa50abe5acb577b84
parent9e5a3f40caa37141d292c6dd5914d4670ab57aff (diff)
downloadopenembedded-core-contrib-0191f500c5b661652d0387c99ba6262979c08293.tar.gz
python-nose: python3-nose should be default
We have nose recipes for both Py2 and Py3, but they both want to ship the unversioned nosetest binary. As Py2 is approaching EOL, remove the unversioned binary from python-nose (leaving nosetest-2.7) instead of renaming the binary to nosetest3 in python3-nose. (From OE-Core rev: e22111a18a0f67fefd1800f67bd5e45637deaa60) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/python/python-nose_1.3.7.bb4
-rw-r--r--meta/recipes-devtools/python/python3-nose_1.3.7.bb4
2 files changed, 4 insertions, 4 deletions
diff --git a/meta/recipes-devtools/python/python-nose_1.3.7.bb b/meta/recipes-devtools/python/python-nose_1.3.7.bb
index 6d69d2d62e..fab609df90 100644
--- a/meta/recipes-devtools/python/python-nose_1.3.7.bb
+++ b/meta/recipes-devtools/python/python-nose_1.3.7.bb
@@ -1,2 +1,6 @@
inherit setuptools
require python-nose.inc
+
+do_install_append() {
+ rm ${D}${bindir}/nosetests
+}
diff --git a/meta/recipes-devtools/python/python3-nose_1.3.7.bb b/meta/recipes-devtools/python/python3-nose_1.3.7.bb
index 8bc1f49835..13dbf96179 100644
--- a/meta/recipes-devtools/python/python3-nose_1.3.7.bb
+++ b/meta/recipes-devtools/python/python3-nose_1.3.7.bb
@@ -1,6 +1,2 @@
inherit setuptools3
require python-nose.inc
-
-do_install_append() {
- mv ${D}${bindir}/nosetests ${D}${bindir}/nosetests3
-}