summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2022-06-21 22:16:28 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2022-06-22 22:40:25 +0100
commitbd63e0a8aaefe6f3ccb8239b51ae4637909f21b2 (patch)
treebd4865c389cedeef89644cd91770f5c1202234dd
parent667264b82156219f9ac50dbb013683ac4fbe0fad (diff)
downloadopenembedded-core-contrib-bd63e0a8aaefe6f3ccb8239b51ae4637909f21b2.tar.gz
ell: update 0.50 -> 0.51
Signed-off-by: Alexander Kanavin <alex@linutronix.de> Signed-off-by: Luca Ceresoli <luca.ceresoli@bootlin.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/ell/ell/0001-build-fix-time.h-related-breakage-on-musl.patch79
-rw-r--r--meta/recipes-core/ell/ell_0.51.bb (renamed from meta/recipes-core/ell/ell_0.50.bb)3
2 files changed, 81 insertions, 1 deletions
diff --git a/meta/recipes-core/ell/ell/0001-build-fix-time.h-related-breakage-on-musl.patch b/meta/recipes-core/ell/ell/0001-build-fix-time.h-related-breakage-on-musl.patch
new file mode 100644
index 0000000000..02b5a9f21e
--- /dev/null
+++ b/meta/recipes-core/ell/ell/0001-build-fix-time.h-related-breakage-on-musl.patch
@@ -0,0 +1,79 @@
+From cd9513a025174181b66ac13de45813f6e15727d3 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Milan=20P=2E=20Stani=C4=87?= <mps@arvanta.net>
+Date: Mon, 6 Jun 2022 22:05:39 +0200
+Subject: [PATCH] build: fix time.h related breakage on musl
+
+missing time.h for struct timeval usage
+forward declaration of struct timeval in time-private.h
+
+Upstream-Status: Backport
+Signed-off-by: Alexander Kanavin <alex@linutronix.de>
+---
+ ell/dhcp-transport.c | 1 +
+ ell/dhcp6-transport.c | 1 +
+ ell/icmp6.c | 1 +
+ ell/time-private.h | 2 +-
+ ell/time.c | 1 +
+ 5 files changed, 5 insertions(+), 1 deletion(-)
+
+diff --git a/ell/dhcp-transport.c b/ell/dhcp-transport.c
+index ef030de..c4cf0ca 100644
+--- a/ell/dhcp-transport.c
++++ b/ell/dhcp-transport.c
+@@ -40,6 +40,7 @@
+ #include <linux/filter.h>
+ #include <net/if_arp.h>
+ #include <errno.h>
++#include <sys/time.h>
+
+ #include "io.h"
+ #include "util.h"
+diff --git a/ell/dhcp6-transport.c b/ell/dhcp6-transport.c
+index 30c425f..5ff6516 100644
+--- a/ell/dhcp6-transport.c
++++ b/ell/dhcp6-transport.c
+@@ -35,6 +35,7 @@
+ #include <net/if.h>
+ #include <unistd.h>
+ #include <errno.h>
++#include <sys/time.h>
+
+ #include "private.h"
+ #include "missing.h"
+diff --git a/ell/icmp6.c b/ell/icmp6.c
+index 368977f..7319903 100644
+--- a/ell/icmp6.c
++++ b/ell/icmp6.c
+@@ -36,6 +36,7 @@
+ #include <net/if.h>
+ #include <unistd.h>
+ #include <errno.h>
++#include <sys/time.h>
+
+ #include "private.h"
+ #include "useful.h"
+diff --git a/ell/time-private.h b/ell/time-private.h
+index 5295d94..83c23dd 100644
+--- a/ell/time-private.h
++++ b/ell/time-private.h
+@@ -19,7 +19,7 @@
+ * Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
+ *
+ */
+-
++struct timeval;
+ uint64_t _time_pick_interval_secs(uint32_t min_secs, uint32_t max_secs);
+ uint64_t _time_fuzz_msecs(uint64_t ms);
+ uint64_t _time_fuzz_secs(uint32_t secs, uint32_t max_offset);
+diff --git a/ell/time.c b/ell/time.c
+index 10e10b0..41e5725 100644
+--- a/ell/time.c
++++ b/ell/time.c
+@@ -26,6 +26,7 @@
+
+ #define _GNU_SOURCE
+ #include <time.h>
++#include <sys/time.h>
+
+ #include "time.h"
+ #include "time-private.h"
diff --git a/meta/recipes-core/ell/ell_0.50.bb b/meta/recipes-core/ell/ell_0.51.bb
index 243ac01530..806833bc7d 100644
--- a/meta/recipes-core/ell/ell_0.50.bb
+++ b/meta/recipes-core/ell/ell_0.51.bb
@@ -15,8 +15,9 @@ DEPENDS = "dbus"
inherit autotools pkgconfig
SRC_URI = "https://mirrors.edge.kernel.org/pub/linux/libs/${BPN}/${BPN}-${PV}.tar.xz \
+ file://0001-build-fix-time.h-related-breakage-on-musl.patch \
"
-SRC_URI[sha256sum] = "0fe51d51c6eddc2a2784092f1dfdd1143a5ef27f15c274ecfbadd680d3a72fd9"
+SRC_URI[sha256sum] = "ba86cfa4aaf10151443edd63a7687914465d969f5dda00a2c1fcb11bd85e417f"
do_configure:prepend () {
mkdir -p ${S}/build-aux