aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2011-02-22 12:28:19 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-02-23 16:23:32 +0000
commit6abfee773fa9696fc7556da0bf78cd153080cb3d (patch)
treedcb4833aa40058529be3fd3dc6ce533c72f8bbe9
parentdca876b8f611704a238842c9e4db293d1a1be247 (diff)
downloadopenembedded-core-contrib-6abfee773fa9696fc7556da0bf78cd153080cb3d.tar.gz
linux-yocto: enable audio for selected qemu targets
Fixes [BUGID #488 #734] Enable audio for qemux86/qemux86-64 via the following kernel configuration options. CONFIG_SOUND_OSS_CORE=y CONFIG_SOUND_OSS_CORE_PRECLAIM=y CONFIG_SND_RAWMIDI=m CONFIG_SND_SEQUENCER=y CONFIG_SND_OSSEMUL=y CONFIG_SND_MIXER_OSS=y CONFIG_SND_PCM_OSS=y CONFIG_SND_PCM_OSS_PLUGINS=y CONFIG_SND_SEQUENCER_OSS=y CONFIG_SND_RAWMIDI_SEQ=m CONFIG_SND_AC97_CODEC=m CONFIG_SND_ENS1370=m CONFIG_SND_INTEL8X0=m CONFIG_AC97_BUS=m The mechanism to trigger these options is in the form of an optional kernel feature that is only appended for qemux86 and qemux86-64, but is contained within the kernel tree. This allows several things: - the options to be available/shared for all boards - the options to be in tree - to not add the options to every board, which unecessarily bloats the default configuration. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com>
-rw-r--r--meta/classes/kernel-yocto.bbclass4
-rw-r--r--meta/conf/distro/include/poky-default-revisions.inc4
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_git.bb6
3 files changed, 9 insertions, 5 deletions
diff --git a/meta/classes/kernel-yocto.bbclass b/meta/classes/kernel-yocto.bbclass
index 15802fabdf..fc9f3a76c0 100644
--- a/meta/classes/kernel-yocto.bbclass
+++ b/meta/classes/kernel-yocto.bbclass
@@ -21,7 +21,9 @@ do_patch() {
# updates or generates the target description
if [ -n "${KERNEL_FEATURES}" ]; then
- addon_features="--features ${KERNEL_FEATURES}"
+ for feat in ${KERNEL_FEATURES}; do
+ addon_features="$addon_features --feature $feat"
+ done
fi
updateme ${addon_features} ${ARCH} ${MACHINE} ${WORKDIR}
if [ $? -ne 0 ]; then
diff --git a/meta/conf/distro/include/poky-default-revisions.inc b/meta/conf/distro/include/poky-default-revisions.inc
index 32f105a2b3..5321c5a503 100644
--- a/meta/conf/distro/include/poky-default-revisions.inc
+++ b/meta/conf/distro/include/poky-default-revisions.inc
@@ -59,7 +59,7 @@ SRCREV_pn-gypsy ??= "3652e1f37e82b8e63983e30fda3482cd099a8cf5"
SRCREV_pn-inputproto ??= "7203036522ba9d4b224d282d6afc2d0b947711ee"
SRCREV_pn-inputproto-native ??= "7203036522ba9d4b224d282d6afc2d0b947711ee"
SRCREV_pn-inputproto-nativesdk ??= "7203036522ba9d4b224d282d6afc2d0b947711ee"
-SRCREV_pn-kern-tools-native ??= "4f13a46499261ea181fdc13db5459067df08aca7"
+SRCREV_pn-kern-tools-native ??= "8f61abb6344e78677450994e8930cabc86102d78"
SRCREV_pn-libdrm ??= "3f3c5be6f908272199ccf53f108b1124bfe0a00e"
SRCREV_pn-libfakekey ??= "e8c2e412ea4a417afc1f30e32cb7bdc508b1dccc"
SRCREV_pn-libgdbus ??= "aeab6e3c0185b271ca343b439470491b99cc587f"
@@ -109,7 +109,7 @@ SRCREV_machine_pn-linux-yocto_routerstationpro ?= "b557fff9c7f864ea2a9c81ac80ec1
SRCREV_machine_pn-linux-yocto_mpc8315e-rdb ?= "8f0124a21f5563b0c51c8426f4430ac222bd463d"
SRCREV_machine_pn-linux-yocto_beagleboard ?= "929567ec621cf99e0932d8ede34f756e25d4c751"
SRCREV_machine_pn-linux-yocto ?= "929567ec621cf99e0932d8ede34f756e25d4c751"
-SRCREV_meta_pn-linux-yocto ?= "29047c254624e0bd8a0ac6da92862f7c6357cb0b"
+SRCREV_meta_pn-linux-yocto ?= "94772ea4f51267a6a9aaffd106035d47dfef1354"
SRCREV_pn-linux-libc-headers-yocto ??= "929567ec621cf99e0932d8ede34f756e25d4c751"
SRCREV_pn-matchbox-config-gtk ??= "3ed74dfb7c57be088a5ab36e446c0ccde9fa1028"
SRCREV_pn-matchbox-desktop-sato ??= "76"
diff --git a/meta/recipes-kernel/linux/linux-yocto_git.bb b/meta/recipes-kernel/linux/linux-yocto_git.bb
index 75c6fb1653..9a3c666ae8 100644
--- a/meta/recipes-kernel/linux/linux-yocto_git.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_git.bb
@@ -17,7 +17,7 @@ KMETA = meta
LINUX_VERSION ?= "2.6.37"
LINUX_VERSION_EXTENSION ?= "-yocto-${LINUX_KERNEL_TYPE}"
-PR = "r15"
+PR = "r16"
PV = "${LINUX_VERSION}+git${SRCPV}"
SRCREV_FORMAT = "meta_machine"
@@ -28,7 +28,9 @@ COMPATIBLE_MACHINE = "(qemuarm|qemux86|qemuppc|qemumips|qemux86-64|mpc8315e-rdb|
# Functionality flags
KERNEL_REVISION_CHECKING ?= "t"
-KERNEL_FEATURES=features/netfilter
+KERNEL_FEATURES="features/netfilter"
+KERNEL_FEATURES_append_qemux86=" cfg/sound"
+KERNEL_FEATURES_append_qemux86-64=" cfg/sound"
# extra tasks
addtask kernel_link_vmlinux after do_compile before do_install