aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2011-02-25 16:18:50 -0800
committerRichard Purdie <rpurdie@linux.intel.com>2011-03-01 11:46:47 +0000
commit68d548cbae729eaea8ce1403dc95ff63c4a7375c (patch)
treea025b058cce2a776efdaa59612fa5f3c3b1eb79a
parent8c9ecdfa3b3bdebc3f86ce3f18d9467c0cc076f8 (diff)
downloadopenembedded-core-contrib-68d548cbae729eaea8ce1403dc95ff63c4a7375c.tar.gz
file: add wrapper to file-native
file-native needs a wrapper to pass the correct path to the magic.mgc file This was found to be the case when sstate-cache is used because file hardcodes the path to the magic.mgc file. [BUGID #775] Signed-off-by: Saul Wold <sgw@linux.intel.com>
-rw-r--r--meta/recipes-devtools/file/file_5.04.bb8
1 files changed, 7 insertions, 1 deletions
diff --git a/meta/recipes-devtools/file/file_5.04.bb b/meta/recipes-devtools/file/file_5.04.bb
index b7451372f5..1f9c78eb7b 100644
--- a/meta/recipes-devtools/file/file_5.04.bb
+++ b/meta/recipes-devtools/file/file_5.04.bb
@@ -10,7 +10,7 @@ LIC_FILES_CHKSUM = "file://COPYING;beginline=2;md5=6a7382872edb68d33e1a9398b6e03
DEPENDS = "zlib file-native"
DEPENDS_virtclass-native = "zlib-native"
-PR = "r1"
+PR = "r2"
SRC_URI = "ftp://ftp.astron.com/pub/file/file-${PV}.tar.gz \
file://stringb-compat.patch \
@@ -30,4 +30,10 @@ do_configure_prepend() {
FILES_${PN} += "${datadir}/misc/*.mgc"
+do_install_append_virtclass-native() {
+ create_cmdline_wrapper ${D}/${bindir}/file \
+ --magic-file ${datadir}/misc/magic.mgc
+}
+
+
BBCLASSEXTEND = "native"