aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2018-08-27 09:55:42 -0700
committerKhem Raj <raj.khem@gmail.com>2018-08-28 10:48:07 -0700
commit62f7c23173a051958c2cf6e8d7a4fce9bd0ef279 (patch)
tree053503f1e3d7cbf3e0def036749ebd7d0e37a76a
parent5e55d18752760c85d54db631bc954ad50bd4f171 (diff)
downloadopenembedded-core-contrib-62f7c23173a051958c2cf6e8d7a4fce9bd0ef279.tar.gz
gpgme: Inherit distutils3-base
its building a module therefore its important to provide correct cross build environment, distutils3-base automatically inherits python3native this is seen when using clang where it tried to link with gcc since the environment falls back to builtin LDSHARED variable Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta/recipes-support/gpgme/gpgme_1.11.1.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-support/gpgme/gpgme_1.11.1.bb b/meta/recipes-support/gpgme/gpgme_1.11.1.bb
index 151fc03f55..ac9fccf133 100644
--- a/meta/recipes-support/gpgme/gpgme_1.11.1.bb
+++ b/meta/recipes-support/gpgme/gpgme_1.11.1.bb
@@ -48,8 +48,8 @@ LANGUAGES ?= "${DEFAULT_LANGUAGES}"
LANGUAGES .= "${@bb.utils.contains('PACKAGECONFIG', 'python2', ' python2', '', d)}"
LANGUAGES .= "${@bb.utils.contains('PACKAGECONFIG', 'python3', ' python3', '', d)}"
-PYTHON_INHERIT = "${@bb.utils.contains('PACKAGECONFIG', 'python2', 'pythonnative', '', d)}"
-PYTHON_INHERIT .= "${@bb.utils.contains('PACKAGECONFIG', 'python3', 'python3native', '', d)}"
+PYTHON_INHERIT = "${@bb.utils.contains('PACKAGECONFIG', 'python2', ' distutils-base', '', d)}"
+PYTHON_INHERIT .= "${@bb.utils.contains('PACKAGECONFIG', 'python3', ' distutils3-base', '', d)}"
EXTRA_OECONF += '--enable-languages="${LANGUAGES}" \
--disable-gpgconf-test \