aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-05-01 02:29:39 +0000
committerKhem Raj <raj.khem@gmail.com>2020-05-01 02:29:39 +0000
commit8acf02147644b92bac20a9215de68709ba9595c2 (patch)
treebea6c35378a0b9b946a4d0f3ac17b3c4939be869
parentcfb8b6dc9b2cd125ff7dd4c13d47e82a48706ebd (diff)
downloadopenembedded-core-contrib-8acf02147644b92bac20a9215de68709ba9595c2.tar.gz
intltool: Build nativesdk and do not use nativeperl
Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--meta/recipes-devtools/intltool/intltool_0.51.0.bb5
1 files changed, 3 insertions, 2 deletions
diff --git a/meta/recipes-devtools/intltool/intltool_0.51.0.bb b/meta/recipes-devtools/intltool/intltool_0.51.0.bb
index a7ea3b727d..0ee101f85c 100644
--- a/meta/recipes-devtools/intltool/intltool_0.51.0.bb
+++ b/meta/recipes-devtools/intltool/intltool_0.51.0.bb
@@ -21,7 +21,8 @@ DEPENDS_class-native = "libxml-parser-perl-native"
inherit autotools pkgconfig perlnative
export PERL = "${bindir}/env perl"
-PERL_class-native = "/usr/bin/env nativeperl"
+PERL_class-native = "/usr/bin/env perl"
+PERL_class-nativesdk = "/usr/bin/env perl"
# gettext is assumed to exist on the host
RDEPENDS_${PN}_class-native = "libxml-parser-perl-native"
@@ -33,4 +34,4 @@ FILES_${PN} += "${datadir}/aclocal"
INSANE_SKIP_${PN} += "dev-deps"
-BBCLASSEXTEND = "native"
+BBCLASSEXTEND = "native nativesdk"