aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2018-08-30 09:45:41 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-08-30 16:16:06 +0100
commita3dbcbdf8a06d54d5587511e0614cb8266591e14 (patch)
tree7d9c5fea81e1ec60e8db62b828094fb7d916368a
parentbbf2a14b970052b6e69c7c8c165a2cf8a06b0dcc (diff)
downloadopenembedded-core-contrib-a3dbcbdf8a06d54d5587511e0614cb8266591e14.tar.gz
kernel-devsrc: fix arm/arm64 target module build
module.lds is required for arch/arm* to build modules out of tree, but isn't required for scripts/prepare, so it was missed in the initial devsrc rework: root@qemuarm64:/tmp# make -C /usr/src/kernel M=/tmp modules make: Entering directory '/lib/modules/4.18.3-yocto-standard/build' CC [M] /tmp/hellomod.o Building modules, stage 2. MODPOST 1 modules CC /tmp/hellomod.mod.o LD [M] /tmp/hellomod.ko make: Leaving directory '/lib/modules/4.18.3-yocto-standard/build' root@qemuarm64:/tmp# insmod hellomod.ko [ 675.743628] hellomod: loading out-of-tree module taints kernel. [ 675.794959] Hello world! Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/linux/kernel-devsrc.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/kernel-devsrc.bb b/meta/recipes-kernel/linux/kernel-devsrc.bb
index b3f529237a..463305e89a 100644
--- a/meta/recipes-kernel/linux/kernel-devsrc.bb
+++ b/meta/recipes-kernel/linux/kernel-devsrc.bb
@@ -146,6 +146,8 @@ do_install() {
cp -a --parents arch/arm64/kernel/vdso/sigreturn.S $kerneldir/build/
cp -a --parents arch/arm64/kernel/vdso/note.S $kerneldir/build/
cp -a --parents arch/arm64/kernel/vdso/gen_vdso_offsets.sh $kerneldir/build/
+
+ cp -a --parents arch/arm64/kernel/module.lds $kerneldir/build/
fi
# include the machine specific headers for ARM variants, if available.
@@ -156,6 +158,8 @@ do_install() {
cp -a --parents arch/arm/tools/gen-mach-types $kerneldir/build/
cp -a --parents arch/arm/tools/mach-types $kerneldir/build/
cp -a --parents arch/arm/tools/syscall* $kerneldir/build/
+
+ cp -a --parents arch/arm/kernel/module.lds $kerneldir/build/
fi
if [ -d arch/${ARCH}/include ]; then