summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2021-08-02 16:37:03 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2021-08-02 16:41:51 +0100
commitcffa5930d86a464aceb4764eec510a2b8f5c44a1 (patch)
tree8e319bb6f8d7eaae05792dccfdc13833f1ee8b09
parent9159db64d3b3c7633deb135e683317fd3e98852c (diff)
downloadopenembedded-core-contrib-cffa5930d86a464aceb4764eec510a2b8f5c44a1.tar.gz
vim: Clarify where RDEPENDS/RRECOMMENDS apply
The tricky of using BPN in a common inc file is rather hard to understand. Simplfy this by moving it to the base vim recipe and use the standard variable form. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-support/vim/vim.inc4
-rw-r--r--meta/recipes-support/vim/vim_8.2.bb4
2 files changed, 4 insertions, 4 deletions
diff --git a/meta/recipes-support/vim/vim.inc b/meta/recipes-support/vim/vim.inc
index 9e4117466e..17d1c24a7c 100644
--- a/meta/recipes-support/vim/vim.inc
+++ b/meta/recipes-support/vim/vim.inc
@@ -140,10 +140,6 @@ FILES:${PN}-common = " \
${datadir}/icons \
"
-RDEPENDS:${BPN} = "ncurses-terminfo-base"
-# Recommend that runtime data is installed along with vim
-RRECOMMENDS:${BPN} = "${PN}-syntax ${PN}-help ${PN}-tutor ${PN}-vimrc ${PN}-common"
-
ALTERNATIVE:${PN} = "vi vim"
ALTERNATIVE_PRIORITY = "100"
ALTERNATIVE_TARGET = "${bindir}/${BPN}.${BPN}"
diff --git a/meta/recipes-support/vim/vim_8.2.bb b/meta/recipes-support/vim/vim_8.2.bb
index 3c1b98dca0..f358e61132 100644
--- a/meta/recipes-support/vim/vim_8.2.bb
+++ b/meta/recipes-support/vim/vim_8.2.bb
@@ -2,6 +2,10 @@ require vim.inc
PROVIDES = "xxd"
+RDEPENDS:${PN} = "ncurses-terminfo-base"
+# Recommend that runtime data is installed along with vim
+RRECOMMENDS:${PN} = "${PN}-syntax ${PN}-help ${PN}-tutor ${PN}-vimrc ${PN}-common"
+
PACKAGECONFIG:class-native = ""
BBCLASSEXTEND = "native nativesdk"