summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndreas Müller <schnitzeltony@gmail.com>2020-06-20 21:02:51 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-06-23 12:27:51 +0100
commita8e5bce0ec329e9fc4b0839e48f2dc3dfec1814d (patch)
treecd34fbe970b47f5b1807966a8a146848ab8e3234
parent7044181df7487f047d175242f7ebbc3c35bf5402 (diff)
downloadopenembedded-core-contrib-a8e5bce0ec329e9fc4b0839e48f2dc3dfec1814d.tar.gz
boost: Add upstream patch to fix build on depending projects
KDE's krita failed with: | error: 'typedef void boost::static_visitor<void>::result_type' is inaccessible within this context Note that only boost 0.173 is affected. 0.172 (dunfell) does not have this problem and the patch will be included in upcoming 0.174. Signed-off-by: Andreas Müller <schnitzeltony@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-support/boost/boost/0001-Make-index-detail-rtree-visitors-insert-base-class-p.patch30
-rw-r--r--meta/recipes-support/boost/boost_1.73.0.bb1
2 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-support/boost/boost/0001-Make-index-detail-rtree-visitors-insert-base-class-p.patch b/meta/recipes-support/boost/boost/0001-Make-index-detail-rtree-visitors-insert-base-class-p.patch
new file mode 100644
index 0000000000..1edad329ca
--- /dev/null
+++ b/meta/recipes-support/boost/boost/0001-Make-index-detail-rtree-visitors-insert-base-class-p.patch
@@ -0,0 +1,30 @@
+From aafbceccc76dccb75963dd4f596fd1f10ee34b03 Mon Sep 17 00:00:00 2001
+From: Jonathan Wakely <boost@kayari.org>
+Date: Fri, 5 Jun 2020 19:29:27 +0100
+Subject: [PATCH] Make index::detail::rtree::visitors::insert base class public
+
+Fixes #721
+
+Upstream-Status: Backport [https://github.com/boostorg/geometry/commit/aafbceccc76dccb75963dd4f596fd1f10ee34b03]
+
+Signed-off-by: Andreas Müller <schnitzeltony@gmail.com>
+---
+ boost/geometry/index/detail/rtree/visitors/insert.hpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/boost/geometry/index/detail/rtree/visitors/insert.hpp b/boost/geometry/index/detail/rtree/visitors/insert.hpp
+index 2d324cb7f..5709a930c 100644
+--- a/boost/geometry/index/detail/rtree/visitors/insert.hpp
++++ b/boost/geometry/index/detail/rtree/visitors/insert.hpp
+@@ -265,7 +265,7 @@ struct insert_traverse_data
+ // Default insert visitor
+ template <typename Element, typename MembersHolder>
+ class insert
+- : MembersHolder::visitor
++ : public MembersHolder::visitor
+ {
+ protected:
+ typedef typename MembersHolder::box_type box_type;
+--
+2.26.2
+
diff --git a/meta/recipes-support/boost/boost_1.73.0.bb b/meta/recipes-support/boost/boost_1.73.0.bb
index 5e9e0d87d7..995c14e8cc 100644
--- a/meta/recipes-support/boost/boost_1.73.0.bb
+++ b/meta/recipes-support/boost/boost_1.73.0.bb
@@ -7,4 +7,5 @@ SRC_URI += "file://arm-intrinsics.patch \
file://0001-Apply-boost-1.62.0-no-forced-flags.patch.patch \
file://0001-Don-t-set-up-arch-instruction-set-flags-we-do-that-o.patch \
file://0001-dont-setup-compiler-flags-m32-m64.patch \
+ file://0001-Make-index-detail-rtree-visitors-insert-base-class-p.patch \
"