aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2011-05-14 18:44:36 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-05-18 14:28:10 +0100
commit1bedd7f3d73c2f9f179f4de4bfaea944a18e49b5 (patch)
treed13e2c6db69091f2fc7b1b3ef9155d50c405fd77
parentd10df0e5a363fe8b305ffac7e8ac231da8e07552 (diff)
downloadopenembedded-core-contrib-1bedd7f3d73c2f9f179f4de4bfaea944a18e49b5.tar.gz
qemu: Fix Dependency and compatible machines
add DEFAULT_PREFERENCE = "-1" to disable git recipe Added libx11 for GL support to DEPENDS Use BROKEN to disable qemuarm and qemumips world build of qemu target Signed-off-by: Saul Wold <sgw@linux.intel.com>
-rw-r--r--meta/recipes-devtools/qemu/qemu.inc10
-rw-r--r--meta/recipes-devtools/qemu/qemu_0.14.0.bb2
-rw-r--r--meta/recipes-devtools/qemu/qemu_git.bb7
3 files changed, 13 insertions, 6 deletions
diff --git a/meta/recipes-devtools/qemu/qemu.inc b/meta/recipes-devtools/qemu/qemu.inc
index 49bcf8e939..18073eb4fc 100644
--- a/meta/recipes-devtools/qemu/qemu.inc
+++ b/meta/recipes-devtools/qemu/qemu.inc
@@ -1,7 +1,7 @@
DESCRIPTION = "open source processor emulator"
HOMEPAGE = "http://qemu.org"
LICENSE = "GPLv2 & LGPLv2.1"
-DEPENDS = "zlib alsa-lib"
+DEPENDS = "zlib alsa-lib qemugl"
# QEMU_TARGETS is overridable variable
QEMU_TARGETS ?= "arm i386 mips mipsel mips64 mips64el ppc sh4 x86_64"
@@ -16,7 +16,6 @@ EXTRA_OECONF += "--target-list=${@get_qemu_target_list(d)} --disable-werror --di
#EXTRA_OECONF += "--disable-sdl"
-COMPATIBLE_MACHINES = "qemux86 qemuppc"
inherit autotools
@@ -43,9 +42,14 @@ do_configure() {
chmod a+x ${S}/target-i386/beginend_funcs.sh
}
-SRC_URI_append_virtclass-nativesdk = " file://glflags.patch;patch=1"
+SRC_URI_append_virtclass-nativesdk = " file://glflags.patch"
+DEPENDS_virtclass-native = "zlib-native alsa-lib-native"
DEPENDS_virtclass-nativesdk = "zlib-nativesdk libsdl-nativesdk qemugl-nativesdk"
RDEPENDS_virtclass-nativesdk = "libsdl-nativesdk"
EXTRA_OECONF_virtclass-nativesdk += "--target-list=${@get_qemu_target_list(d)} --disable-werror --disable-vnc-tls"
BBCLASSEXTEND = "native nativesdk"
+
+# Qemu target will not build in world build for ARM or Mips
+BROKEN_qemuarm = "1"
+BROKEN_qemumips = "1"
diff --git a/meta/recipes-devtools/qemu/qemu_0.14.0.bb b/meta/recipes-devtools/qemu/qemu_0.14.0.bb
index f0a4beae1c..ccf5ee4f2d 100644
--- a/meta/recipes-devtools/qemu/qemu_0.14.0.bb
+++ b/meta/recipes-devtools/qemu/qemu_0.14.0.bb
@@ -3,7 +3,7 @@ require qemu.inc
LIC_FILES_CHKSUM = "file://COPYING;md5=441c28d2cf86e15a37fa47e15a72fbac \
file://COPYING.LIB;endline=24;md5=c04def7ae38850e7d3ef548588159913"
-PR = "r1"
+PR = "r2"
FILESPATH = "${FILE_DIRNAME}/qemu-${PV}"
FILESDIR = "${WORKDIR}"
diff --git a/meta/recipes-devtools/qemu/qemu_git.bb b/meta/recipes-devtools/qemu/qemu_git.bb
index 2d6a8bdd65..59fc7f1396 100644
--- a/meta/recipes-devtools/qemu/qemu_git.bb
+++ b/meta/recipes-devtools/qemu/qemu_git.bb
@@ -5,8 +5,8 @@ SRCREV = "56a60dd6d619877e9957ba06b92d2f276e3c229d"
LIC_FILES_CHKSUM = "file://COPYING;md5=441c28d2cf86e15a37fa47e15a72fbac \
file://COPYING.LIB;endline=24;md5=c04def7ae38850e7d3ef548588159913"
-PV = "0.14"
-PR = "r0"
+PV = "0.14.0"
+PR = "r1"
FILESPATH = "${FILE_DIRNAME}/qemu-${PV}/:${FILE_DIRNAME}/qemu-git/"
FILESDIR = "${WORKDIR}"
@@ -23,3 +23,6 @@ SRC_URI = "\
S = "${WORKDIR}/git"
+DEFAULT_PREFERENCE = "-1"
+
+