aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2016-08-31 17:51:23 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-08-31 22:00:03 +0100
commit227bb71bcc74f33609a047c51026e48807cd0610 (patch)
tree1480b8531c82e00fb1526c9bf8a86fbf36686379
parentc70161457f24e57bf0df7c179829319bfcd940c4 (diff)
downloadopenembedded-core-contrib-227bb71bcc74f33609a047c51026e48807cd0610.tar.gz
bdwgc: Add missing include to avoid musl build failures
Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-support/bdwgc/bdwgc/musl_header_fix.patch27
-rw-r--r--meta/recipes-support/bdwgc/bdwgc_7.6.0.bb1
2 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-support/bdwgc/bdwgc/musl_header_fix.patch b/meta/recipes-support/bdwgc/bdwgc/musl_header_fix.patch
new file mode 100644
index 0000000000..4a18496650
--- /dev/null
+++ b/meta/recipes-support/bdwgc/bdwgc/musl_header_fix.patch
@@ -0,0 +1,27 @@
+Add missing header to avoid:
+
+| 1472659610.016355: ../git/pthread_stop_world.c: In function 'GC_brief_async_signal_safe_sleep':
+| 1472659610.0540252: ../git/pthread_stop_world.c:397:22: error: storage size of 'tv' isn't known
+| 1472659610.0540252: struct timeval tv;
+| 1472659610.0540252: ^~
+| 1472659610.054099: ../git/pthread_stop_world.c:397:22: warning: unused variable 'tv' [-Wunused-variable]
+| 1472659610.054099: struct timeval tv;
+| 1472659610.054099: ^~
+| 1472659610.054099: Makefile:1530: recipe for target 'pthread_stop_world.lo' failed
+
+in musl builds.
+
+Upstream-Status: Pending
+
+Index: git/pthread_stop_world.c
+===================================================================
+--- git.orig/pthread_stop_world.c
++++ git/pthread_stop_world.c
+@@ -45,6 +45,7 @@
+ #include <semaphore.h>
+ #include <errno.h>
+ #include <unistd.h>
++#include <sys/time.h>
+ #include "atomic_ops.h"
+
+ /* It's safe to call original pthread_sigmask() here. */
diff --git a/meta/recipes-support/bdwgc/bdwgc_7.6.0.bb b/meta/recipes-support/bdwgc/bdwgc_7.6.0.bb
index 55ea452068..dcb68f0282 100644
--- a/meta/recipes-support/bdwgc/bdwgc_7.6.0.bb
+++ b/meta/recipes-support/bdwgc/bdwgc_7.6.0.bb
@@ -24,6 +24,7 @@ LIC_FILES_CHKSUM = "file://README.QUICK;md5=4f81f24ec69726c312487c2ac740e9e3"
SRCREV = "8ac1d84a40eb7a431fec1b8097e3f24b48fb23fa"
SRC_URI = "git://github.com/ivmai/bdwgc.git \
file://0001-configure.ac-add-check-for-NO_GETCONTEXT-definition.patch \
+ file://musl_header_fix.patch \
"
FILES_${PN}-doc = "${datadir}"