aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoshua Lock <joshua.g.lock@intel.com>2017-03-08 14:36:14 +0000
committerJoshua Lock <joshua.g.lock@intel.com>2017-03-08 17:01:34 +0000
commit9eb2ab3ea56760f25d9acccab2231394ee2e0f8e (patch)
tree67ccdcd4730284eba620d9b84b518b5aeed7bdb0
parent17654b4d7d09bb1bd4f7d3471c6bfef7eeef2e59 (diff)
downloadopenembedded-core-contrib-9eb2ab3ea56760f25d9acccab2231394ee2e0f8e.tar.gz
lib/oeqa/selftest/oescripts: make test_cleanup_workdir use selftest-ed
Use a recipe which is bundled in the meta-selftest layer for this test, rather than relying on OE-Core remaining static (or updating the tests when OE-Core changes recipes). Tested with oe-selftest -r oescripts.TestScripts.test_cleanup_workdir Signed-off-by: Joshua Lock <joshua.g.lock@intel.com>
-rw-r--r--meta/lib/oeqa/selftest/oescripts.py10
1 files changed, 5 insertions, 5 deletions
diff --git a/meta/lib/oeqa/selftest/oescripts.py b/meta/lib/oeqa/selftest/oescripts.py
index 28345dc6a2..baf3b6ab2c 100644
--- a/meta/lib/oeqa/selftest/oescripts.py
+++ b/meta/lib/oeqa/selftest/oescripts.py
@@ -14,10 +14,10 @@ class TestScripts(oeSelfTest):
@testcase(300)
def test_cleanup_workdir(self):
- path = os.path.dirname(get_bb_var('WORKDIR', 'gzip'))
- old_version_recipe = os.path.join(get_bb_var('COREBASE'), 'meta/recipes-extended/gzip/gzip_1.3.12.bb')
- old_version = '1.3.12'
- bitbake("-c clean gzip")
+ path = os.path.dirname(get_bb_var('WORKDIR', 'selftest-ed'))
+ old_version_recipe = os.path.join(get_bb_var('COREBASE'), 'meta-selftest/recipes-test/selftest-ed/selftest-ed_0.5.bb')
+ old_version = '0.5'
+ bitbake("-c clean selftest-ed")
bitbake("-c clean -b %s" % old_version_recipe)
if os.path.exists(path):
@@ -25,7 +25,7 @@ class TestScripts(oeSelfTest):
else:
initial_contents = []
- bitbake('gzip')
+ bitbake('selftest-ed')
intermediary_contents = os.listdir(path)
bitbake("-b %s" % old_version_recipe)
runCmd('cleanup-workdir')