summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnuj Mittal <anuj.mittal@intel.com>2020-07-10 08:09:59 +0800
committerAnuj Mittal <anuj.mittal@intel.com>2020-07-28 16:16:52 +0800
commit74e22d0d2b61d0014f408972725469bb7a024622 (patch)
treef8aa50f634364ba32c1f56da395f6bf10a9a785b
parent2adcc5ade62fe10715a6c943565f71efe7627229 (diff)
downloadopenembedded-core-contrib-74e22d0d2b61d0014f408972725469bb7a024622.tar.gz
gstreamer1.0: fix builds with make 4.3
Depend on make-native instead of using host make to avoid errors like: | controller-enumtypes.c:10:1: error: stray '\' in program | 10 | \#include "gstinterpolationcontrolsource.h" | | ^ | controller-enumtypes.c:10:2: error: stray '#' in program | 10 | \#include "gstinterpolationcontrolsource.h" | | ^ | controller-enumtypes.c:10:11: error: expected '=', ',', ';', 'asm' or '__attribute__' before string constant | 10 | \#include "gstinterpolationcontrolsource.h" | | ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ | controller-enumtypes.c:11:1: error: stray '\' in program | 11 | \#include "gstlfocontrolsource.h" | | ^ | controller-enumtypes.c:11:2: error: stray '#' in program | 11 | \#include "gstlfocontrolsource.h" This helps building on autobuilder where some workers have buildtools with make 4.3 installed. Building using meson works fine so later branches are not affected and upstream has rejected patches to fix this: https://gitlab.freedesktop.org/gstreamer/gstreamer/-/issues/515 Signed-off-by: Anuj Mittal <anuj.mittal@intel.com>
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins.inc2
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0-rtsp-server_1.16.2.bb2
-rw-r--r--meta/recipes-multimedia/gstreamer/gstreamer1.0_1.16.2.bb2
3 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins.inc b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins.inc
index bc24b05fec..92b473add6 100644
--- a/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins.inc
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-plugins.inc
@@ -3,7 +3,7 @@ HOMEPAGE = "http://gstreamer.freedesktop.org/"
BUGTRACKER = "https://bugzilla.gnome.org/enter_bug.cgi?product=Gstreamer"
SECTION = "multimedia"
-DEPENDS = "gstreamer1.0 glib-2.0-native"
+DEPENDS = "gstreamer1.0 glib-2.0-native make-native"
SRC_URI_append = " file://gtk-doc-tweaks.patch"
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0-rtsp-server_1.16.2.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0-rtsp-server_1.16.2.bb
index 15ef5d1b28..b7470b0047 100644
--- a/meta/recipes-multimedia/gstreamer/gstreamer1.0-rtsp-server_1.16.2.bb
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0-rtsp-server_1.16.2.bb
@@ -4,7 +4,7 @@ SECTION = "multimedia"
LICENSE = "LGPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=6762ed442b3822387a51c92d928ead0d"
-DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base"
+DEPENDS = "gstreamer1.0 gstreamer1.0-plugins-base make-native"
PNREAL = "gst-rtsp-server"
diff --git a/meta/recipes-multimedia/gstreamer/gstreamer1.0_1.16.2.bb b/meta/recipes-multimedia/gstreamer/gstreamer1.0_1.16.2.bb
index cf7c1bca12..96a6ade22b 100644
--- a/meta/recipes-multimedia/gstreamer/gstreamer1.0_1.16.2.bb
+++ b/meta/recipes-multimedia/gstreamer/gstreamer1.0_1.16.2.bb
@@ -6,7 +6,7 @@ BUGTRACKER = "https://bugzilla.gnome.org/enter_bug.cgi?product=Gstreamer"
SECTION = "multimedia"
LICENSE = "LGPLv2+"
-DEPENDS = "glib-2.0 glib-2.0-native libcap libxml2 bison-native flex-native"
+DEPENDS = "glib-2.0 glib-2.0-native libcap libxml2 bison-native flex-native make-native"
inherit autotools pkgconfig gettext upstream-version-is-even gobject-introspection gtk-doc ptest