aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoryanjun.zhu <yanjun.zhu@windriver.com>2014-03-31 22:41:08 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2014-03-31 17:44:17 +0100
commitaf595b09d570cbd320e4e138651144ac96bfbb83 (patch)
treeb4418d06b4ac8d3123a25b9ff8692e226b53f5c6
parentff321fec0c5611b69a99901cac74bfd76b409d77 (diff)
downloadopenembedded-core-contrib-af595b09d570cbd320e4e138651144ac96bfbb83.tar.gz
pseudo-1.5.1: keep install command directory mode
When install command sets the created directory mode, pseudo will change the mode of the directory to 0700 incorrectly. Backport patch to fix it. Signed-off-by: yanjun.zhu <yanjun.zhu@windriver.com> Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/pseudo/files/pseudo-1.5.1-install-directory-mode.patch18
-rw-r--r--meta/recipes-devtools/pseudo/pseudo_1.5.1.bb1
2 files changed, 19 insertions, 0 deletions
diff --git a/meta/recipes-devtools/pseudo/files/pseudo-1.5.1-install-directory-mode.patch b/meta/recipes-devtools/pseudo/files/pseudo-1.5.1-install-directory-mode.patch
new file mode 100644
index 0000000000..e8eaf13f74
--- /dev/null
+++ b/meta/recipes-devtools/pseudo/files/pseudo-1.5.1-install-directory-mode.patch
@@ -0,0 +1,18 @@
+Upstream-Status: Backport
+
+when install command sets the created directory mode, pseudo will change
+the mode of the directory to 0700 incorrectly.
+
+Signed-off-by: yanjun.zhu <yanjun.zhu@windriver.com>
+Signed-off-by: Kai Kang <kai.kang@windriver.com>
+
+--- a/ports/unix/guts/mkdirat.c
++++ b/ports/unix/guts/mkdirat.c
+@@ -25,6 +25,7 @@
+ stat_rc = base_fstatat(dirfd, path, &buf, AT_SYMLINK_NOFOLLOW);
+ #endif
+ if (stat_rc != -1) {
++ buf.st_mode = PSEUDO_DB_MODE(buf.st_mode, mode);
+ pseudo_client_op(OP_MKDIR, 0, -1, dirfd, path, &buf);
+ } else {
+ pseudo_debug(1, "mkdir of %s succeeded, but stat failed: %s\n",
diff --git a/meta/recipes-devtools/pseudo/pseudo_1.5.1.bb b/meta/recipes-devtools/pseudo/pseudo_1.5.1.bb
index bc928569df..215cdb8bcc 100644
--- a/meta/recipes-devtools/pseudo/pseudo_1.5.1.bb
+++ b/meta/recipes-devtools/pseudo/pseudo_1.5.1.bb
@@ -6,6 +6,7 @@ SRC_URI = " \
http://www.yoctoproject.org/downloads/${BPN}/${BPN}-${PV}.tar.bz2 \
file://0001-pseudo_has_unload-add-function.patch \
file://shutdownping.patch \
+ file://pseudo-1.5.1-install-directory-mode.patch \
"
SRC_URI[md5sum] = "5ec67c7bff5fe68c56de500859c19172"