summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-02-19 15:18:45 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-02-21 09:32:01 +0000
commitc8bd926cfa2f74ca59c379072c40322605a76bd2 (patch)
tree679fefcacbd70991f23f761f5e00f2c253d2cdf9
parentb53edb86c65ad375df153017f245244ef97f3932 (diff)
downloadopenembedded-core-contrib-c8bd926cfa2f74ca59c379072c40322605a76bd2.tar.gz
freetype: use autotools instead of a manual do_configure
autotools.bbclass has enough variables now that we can use it instead of hand-coding a do_configure. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-graphics/freetype/freetype_2.6.3.bb18
1 files changed, 5 insertions, 13 deletions
diff --git a/meta/recipes-graphics/freetype/freetype_2.6.3.bb b/meta/recipes-graphics/freetype/freetype_2.6.3.bb
index cf6882af9e..3ed9070120 100644
--- a/meta/recipes-graphics/freetype/freetype_2.6.3.bb
+++ b/meta/recipes-graphics/freetype/freetype_2.6.3.bb
@@ -20,6 +20,11 @@ SRC_URI[sha256sum] = "371e707aa522acf5b15ce93f11183c725b8ed1ee8546d7b3af54986304
inherit autotools pkgconfig binconfig-disabled multilib_header
+# Adapt autotools to work with the minimal autoconf usage in freetype
+AUTOTOOLS_SCRIPT_PATH = "${S}/builds/unix"
+CONFIGURE_SCRIPT = "${S}/configure"
+EXTRA_AUTORECONF += "--exclude=autoheader --exclude=automake"
+
PACKAGECONFIG ??= "zlib"
PACKAGECONFIG[bzip2] = "--with-bzip2,--without-bzip2,bzip2"
@@ -32,19 +37,6 @@ EXTRA_OECONF = "CC_BUILD='${BUILD_CC}'"
TARGET_CPPFLAGS += "-D_FILE_OFFSET_BITS=64"
-do_configure() {
- # Need this because although the autotools infrastructure is in
- # builds/unix the configure script get written to ${S}, so we can't
- # just use AUTOTOOLS_SCRIPT_PATH.
- cd ${S}/builds/unix
- libtoolize --force --copy
- aclocal -I .
- gnu-configize --force
- autoconf
- cd ${B}
- oe_runconf
-}
-
do_install_append() {
oe_multilib_header freetype2/freetype/config/ftconfig.h
}