aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoshua Lock <josh@linux.intel.com>2010-03-19 14:59:49 +0000
committerJoshua Lock <josh@linux.intel.com>2010-03-19 14:59:49 +0000
commitd296df43975bb99586a023dceb064a867ce304b1 (patch)
tree1b2d52ff025b59674db420f144c352f4a93aed62
parent34e1b3ef1ce646420c228734d43eca5d71f5ccf8 (diff)
downloadopenembedded-core-contrib-d296df43975bb99586a023dceb064a867ce304b1.tar.gz
claws-mail: Fix building with new automake
Having the same file listed multiple times in Makefile.am breaks with new Autotools Signed-off-by: Joshua Lock <josh@linux.intel.com>
-rw-r--r--meta/packages/claws-mail/claws-mail.inc6
-rw-r--r--meta/packages/claws-mail/files/fix-build.patch24
2 files changed, 28 insertions, 2 deletions
diff --git a/meta/packages/claws-mail/claws-mail.inc b/meta/packages/claws-mail/claws-mail.inc
index f3208a169c..04401df2f5 100644
--- a/meta/packages/claws-mail/claws-mail.inc
+++ b/meta/packages/claws-mail/claws-mail.inc
@@ -3,13 +3,14 @@ DESCRIPTION = "Mail user agent"
#DEPENDS = "gtk+ gpgme libetpan libgnomeprint aspell openssl"
DEPENDS = "gtk+ libetpan openssl libowl"
LICENSE = "GPL"
-PR = "r5"
+PR = "r6"
SRC_URI = "\
${SOURCEFORGE_MIRROR}/sylpheed-claws/claws-mail-${PV}.tar.bz2 \
file://desktop.patch;patch=1 \
file://streamline-ui.patch;patch=1 \
file://owl-window-menu.patch;patch=1 \
+ file://fix-build.patch;patch=1 \
"
FILES_${PN} = "${bindir} ${datadir}/pixmaps ${datadir}/applications"
@@ -35,11 +36,12 @@ EXTRA_OECONF = "--disable-aspell-test \
# --disable-libetpan \
--disable-gnomeprint \
--disable-valgrind \
+ --disable-static \
"
CFLAGS += "-D_GNU_SOURCE"
-inherit autotools_stage pkgconfig gettext
+inherit autotools pkgconfig gettext
do_install_append() {
install -d ${D}${datadir}/applications
diff --git a/meta/packages/claws-mail/files/fix-build.patch b/meta/packages/claws-mail/files/fix-build.patch
new file mode 100644
index 0000000000..2f30899fe1
--- /dev/null
+++ b/meta/packages/claws-mail/files/fix-build.patch
@@ -0,0 +1,24 @@
+Remove duplicate file entries as this breaks install with new Automake
+
+JL 19/03/10
+
+Index: claws-mail-2.9.1/src/gtk/Makefile.am
+===================================================================
+--- claws-mail-2.9.1.orig/src/gtk/Makefile.am 2007-03-22 07:52:47.000000000 +0000
++++ claws-mail-2.9.1/src/gtk/Makefile.am 2010-03-19 14:54:06.565828281 +0000
+@@ -44,7 +44,6 @@
+ filesel.h \
+ foldersort.h \
+ gtkaspell.h \
+- gtksctree.h \
+ gtkshruler.h \
+ gtksctree.h \
+ gtksourceprintjob.h \
+@@ -57,7 +56,6 @@
+ menu.h \
+ pluginwindow.h \
+ prefswindow.h \
+- gtkvscrollbutton.h \
+ progressdialog.h \
+ quicksearch.h \
+ sslcertwindow.h \