summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2019-05-15 15:45:14 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-05-15 17:52:49 +0100
commitfa24a5056acea6610e2ad1a1eb1e7425a3828979 (patch)
treedadb9d768512404b29c1da33911f19ee0668a347
parent5fdb96f4996856286c4f72b93d31b7990ceed8aa (diff)
downloadopenembedded-core-contrib-fa24a5056acea6610e2ad1a1eb1e7425a3828979.tar.gz
core-image-sato-sdk-ptest: Tweak size to stay within 4GB limit
Adding the valgrind debug symbol information caused the genericx86-64 image to overflow the 4GB boundary. Tweak the sizes to avoid autobuilder failures yet leave enough space all the tests still run successfully. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-sato/images/core-image-sato-sdk-ptest.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-sato/images/core-image-sato-sdk-ptest.bb b/meta/recipes-sato/images/core-image-sato-sdk-ptest.bb
index 2497fc42ae..e84beda6ce 100644
--- a/meta/recipes-sato/images/core-image-sato-sdk-ptest.bb
+++ b/meta/recipes-sato/images/core-image-sato-sdk-ptest.bb
@@ -12,10 +12,10 @@ IMAGE_INSTALL += "${PTESTS_FAST} ${PTESTS_SLOW}"
# This image is sufficiently large (~1.8GB) that we need to be careful that it fits in a live
# image (which has a 4GB limit), so nullify the overhead factor (1.3x out of the
-# box) and explicitly add just 1300MB.
+# box) and explicitly add just 1200MB.
# strace-ptest in particular needs more than 500MB
IMAGE_OVERHEAD_FACTOR = "1.0"
-IMAGE_ROOTFS_EXTRA_SPACE = "1324288"
+IMAGE_ROOTFS_EXTRA_SPACE = "1224288"
# ptests need more memory than standard to avoid the OOM killer
QB_MEM = "-m 1024"