summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLiwei Song <liwei.song@windriver.com>2019-05-15 22:41:40 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2019-05-16 16:35:06 +0100
commitbe24f1dc995f7a996abfa551abea74f06de19ae6 (patch)
tree16d3902f2146df9acc47556df3a25095acde3764
parent3ee977629331843cc811b6571d13fa02f5593a10 (diff)
downloadopenembedded-core-contrib-be24f1dc995f7a996abfa551abea74f06de19ae6.tar.gz
mdadm: install the systemd service through Makefile
The original mdadm service may include variable like BINDIR, It should use the real value of it, since the install method "install-systemd" in Makefile can easily do such work, so don't install it in bb file manually, use "make install-systemd" to install all the service of mdadm. Signed-off-by: Liwei Song <liwei.song@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-extended/mdadm/mdadm_4.1.bb10
1 files changed, 7 insertions, 3 deletions
diff --git a/meta/recipes-extended/mdadm/mdadm_4.1.bb b/meta/recipes-extended/mdadm/mdadm_4.1.bb
index ef5ddf55db..597faf787a 100644
--- a/meta/recipes-extended/mdadm/mdadm_4.1.bb
+++ b/meta/recipes-extended/mdadm/mdadm_4.1.bb
@@ -57,13 +57,15 @@ do_install() {
do_install_append() {
install -d ${D}/${sysconfdir}/
install -m 644 ${S}/mdadm.conf-example ${D}${sysconfdir}/mdadm.conf
- install -d ${D}/${systemd_unitdir}/system
- install -m 644 ${WORKDIR}/mdmonitor.service ${D}/${systemd_unitdir}/system
- install -m 644 ${S}/systemd/mdmon@.service ${D}/${systemd_unitdir}/system
install -d ${D}/${sysconfdir}/init.d
install -m 755 ${WORKDIR}/mdadm.init ${D}${sysconfdir}/init.d/mdmonitor
}
+do_install_append() {
+ oe_runmake install-systemd DESTDIR=${D}
+}
+
+
do_compile_ptest() {
oe_runmake test
}
@@ -90,3 +92,5 @@ RRECOMMENDS_${PN}-ptest += " \
kernel-module-raid10 \
kernel-module-raid456 \
"
+
+FILES_${PN} += "/lib/systemd/*"