summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2018-03-04 11:49:08 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2019-05-20 15:56:01 +0000
commit5b5685efb256f9e63c4c8ca50d1a6e6deb3f2f31 (patch)
tree9dd65df7ea79b800b00dd0ca054529d71020fd85
parentdfdebdaab91d0f1b6a3967a8429f2e843940bee8 (diff)
downloadopenembedded-core-contrib-5b5685efb256f9e63c4c8ca50d1a6e6deb3f2f31.tar.gz
pseudo-test: add dummy recipe to reproduce YOCTO #12434
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta/recipes-devtools/pseudo/pseudo-test.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-devtools/pseudo/pseudo-test.bb b/meta/recipes-devtools/pseudo/pseudo-test.bb
new file mode 100644
index 0000000000..440a40057c
--- /dev/null
+++ b/meta/recipes-devtools/pseudo/pseudo-test.bb
@@ -0,0 +1,29 @@
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+DEPENDS = "qtbase-native"
+CLEANBROKEN = "1"
+
+inherit qmake5_paths
+
+RULES = "999"
+PARALLEL_MAKE = "-j 30"
+
+do_compile() {
+ # with normall install command it doesn't trigger the issue
+ # echo "QINSTALL = ${STAGING_BINDIR_NATIVE}/install" > Makefile
+ /bin/echo "QINSTALL = ${OE_QMAKE_PATH_EXTERNAL_HOST_BINS}/qmake -install qinstall" > Makefile
+ ALL="all: "
+ for i in `seq -w 1 ${RULES}`; do
+ /bin/echo $i > ${S}/$i.txt
+ /bin/echo -e "R$i:\n\t\$(QINSTALL) ${S}/$i.txt ${D}/$i.txt && mv ${D}/$i.txt ${D}/`expr $i + 1`.txt" >> Makefile;
+ ALL="$ALL R$i"
+ done
+ /bin/echo ${ALL} >> Makefile
+}
+
+do_install() {
+ oe_runmake all
+}
+
+FILES_${PN} = "/"