summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2018-03-04 11:49:08 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2019-03-24 11:13:28 +0100
commit058d9095b19c0c09952d96820ccb022044eafeee (patch)
treecddd626d1c5d82ec498fc3355cca3c79ed0b937a
parent8a37431f60ac5fa8c04ceb08cba3448264c33fdb (diff)
downloadopenembedded-core-contrib-058d9095b19c0c09952d96820ccb022044eafeee.tar.gz
pseudo-text: add dummy recipe to reproduce YOCTO #12434
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--meta/recipes-devtools/pseudo/pseudo-test.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta/recipes-devtools/pseudo/pseudo-test.bb b/meta/recipes-devtools/pseudo/pseudo-test.bb
new file mode 100644
index 0000000000..90581ef763
--- /dev/null
+++ b/meta/recipes-devtools/pseudo/pseudo-test.bb
@@ -0,0 +1,21 @@
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/MIT;md5=0835ade698e0bcf8506ecda2f7b4f302"
+
+inherit allarch
+
+DEPENDS = "coreutils-native"
+CLEANBROKEN = "1"
+
+RULES = "1000"
+
+do_compile() {
+ echo > Makefile; ALL="all: "; for i in `seq -w 1 ${RULES}`; do echo -e "R$i:\n\techo $i > foo.txt" >> Makefile; ALL="$ALL R$i"; done; echo ${ALL} >> Makefile
+}
+
+do_install() {
+ oe_runmake all
+ cat foo.txt
+ mv foo.txt ${D}
+}
+
+FILES_${PN} = "/"