aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2013-06-19 14:55:32 +0100
committerSaul Wold <sgw@linux.intel.com>2013-07-02 07:46:03 -0700
commit37890014f406ca2ab24e0ec918af39613642afa0 (patch)
treeda37708511e5be3816db87f6fd1f55c2bfa80a86
parent31bc9fa8d53110a09ca048039d83213b34f4b7e4 (diff)
downloadopenembedded-core-contrib-37890014f406ca2ab24e0ec918af39613642afa0.tar.gz
python-smmap: add recipe
This is required by python-gitdb. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
-rw-r--r--meta/recipes-devtools/python/python-smmap_0.8.2.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-devtools/python/python-smmap_0.8.2.bb b/meta/recipes-devtools/python/python-smmap_0.8.2.bb
new file mode 100644
index 0000000000..64f812de00
--- /dev/null
+++ b/meta/recipes-devtools/python/python-smmap_0.8.2.bb
@@ -0,0 +1,20 @@
+SUMMARY = "Python implementation of a sliding window memory map manager"
+DESCRIPTION = "A pure Python implementation of a sliding memory map to \
+help unifying memory mapped access on 32 and 64 bit systems and to help \
+managing resources more efficiently."
+HOMEPAGE = "http://github.com/gitpython-developers/GitPython"
+SECTION = "devel/python"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://PKG-INFO;beginline=8;endline=8;md5=e910b35b0ef4e1f665b9a75d6afb7709"
+
+SRC_URI = "http://pypi.python.org/packages/source/s/smmap/smmap-${PV}.tar.gz"
+SRC_URI[md5sum] = "f5426b7626ddcf5e447253fae0396b0c"
+SRC_URI[sha256sum] = "dea2955cc045ec5527da6b762f7e95a5be7f645c683b54ccce52d56b4d7e2d6f"
+
+S = "${WORKDIR}/smmap-${PV}"
+
+inherit setuptools
+
+RDEPENDS_${PN} += "python-codecs python-mmap python-lang"
+
+BBCLASSEXTEND = "nativesdk"