summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2023-11-18 22:05:49 +0100
committerMartin Jansa <martin.jansa@gmail.com>2024-04-25 18:51:43 +0200
commitc9400a474657982ad17b229295553e871e0799a3 (patch)
tree0c2b10686aea583c8ff028bba6e8045adea15f15
parentf65fc3fe2ff7d9cbaeb0cbc91f16d1f7c6be2d89 (diff)
downloadopenembedded-core-contrib-c9400a474657982ad17b229295553e871e0799a3.tar.gz
selftest: multiconfig-image-packager: use IMAGE_NAME instead of IMAGE_LINK_NAME
* the IMAGE_LINK_NAME now contains PKGV, PKGR in the filename, but the multiconfig-image-packager and MC_DEPLOY_IMAGE_BASENAME (e.g. core-image-minimal) has different PKGV value causing: | DEBUG: Executing shell function do_install | install: cannot stat 'tmp-mc-musl/deploy/images/qemux86-64/core-image-minimal-qemux86-64.rootfs--0.1-r0-20110405230000.ext4': No such file or directory ... | install: cannot stat 'tmp-mc-tiny/deploy/images/qemux86/core-image-minimal-qemux86.rootfs--0.1-r0-20110405230000.cpio.gz': No such file or directory because the actual filenames are: tmp-mc-musl/deploy/images/qemux86-64/core-image-minimal-qemux86-64.rootfs--1.0-r0-20110405230000.ext4 tmp-mc-tiny/deploy/images/qemux86/core-image-minimal-qemux86.rootfs--1.0-r0-20110405230000.ext4 [YOCTO #12937] Signed-off-by: Martin Jansa <martin.jansa@gmail.com>
-rw-r--r--meta-selftest/recipes-test/multiconfig/multiconfig-image-packager_0.1.bb12
1 files changed, 6 insertions, 6 deletions
diff --git a/meta-selftest/recipes-test/multiconfig/multiconfig-image-packager_0.1.bb b/meta-selftest/recipes-test/multiconfig/multiconfig-image-packager_0.1.bb
index d7785cee2e..b53b6a4b26 100644
--- a/meta-selftest/recipes-test/multiconfig/multiconfig-image-packager_0.1.bb
+++ b/meta-selftest/recipes-test/multiconfig/multiconfig-image-packager_0.1.bb
@@ -13,11 +13,11 @@ do_install[mcdepends] += "mc::${MCNAME}:core-image-minimal:do_image_complete mc:
do_install () {
install -d ${D}/var/lib/machines/${MCNAME}
- install ${MC_DEPLOY_DIR_IMAGE}/${IMAGE_LINK_NAME_CORE_IMAGE_MINIMAL}.${MCIMGTYPE} ${D}/var/lib/machines/${MCNAME}/${MC_DEPLOY_IMAGE_BASENAME}.${MCIMGTYPE}
+ install ${MC_DEPLOY_DIR_IMAGE}/${IMAGE_NAME_CORE_IMAGE_MINIMAL}.${MCIMGTYPE} ${D}/var/lib/machines/${MCNAME}/${MC_DEPLOY_IMAGE_BASENAME}.${MCIMGTYPE}
install ${MC_DEPLOY_DIR_IMAGE}/bzImage ${D}/var/lib/machines/${MCNAME}
}
-# for IMAGE_LINK_NAME, IMAGE_BASENAME
+# for IMAGE_NAME, IMAGE_BASENAME
inherit image-artifact-names
python () {
@@ -31,14 +31,14 @@ python () {
# these will most likely start with my BPN multiconfig-image-packager, but I want them from core-image-minimal
# as there is no good way to query core-image-minimal's context lets assume that there are no overrides
# and that we can just replace IMAGE_BASENAME
- image_link_name = d.getVar('IMAGE_LINK_NAME')
+ image_name = d.getVar('IMAGE_NAME')
image_basename = d.getVar('IMAGE_BASENAME')
machine = d.getVar('MACHINE')
mcmachine = d.getVar('MCMACHINE')
image_to_deploy = d.getVar('MC_DEPLOY_IMAGE_BASENAME')
- image_link_name_to_deploy = image_link_name.replace(image_basename, image_to_deploy).replace(machine, mcmachine)
- bb.warn('%s: assuming that "%s" built for "%s" has IMAGE_LINK_NAME "%s"' % (d.getVar('PN'), mcmachine, image_to_deploy, image_link_name_to_deploy))
- d.setVar('IMAGE_LINK_NAME_CORE_IMAGE_MINIMAL', image_link_name_to_deploy)
+ image_name_to_deploy = image_name.replace(image_basename, image_to_deploy).replace(machine, mcmachine)
+ bb.warn('%s: assuming that "%s" built for "%s" has IMAGE_NAME "%s"' % (d.getVar('PN'), mcmachine, image_to_deploy, image_name_to_deploy))
+ d.setVar('IMAGE_NAME_CORE_IMAGE_MINIMAL', image_name_to_deploy)
}
BBCLASSEXTEND = "mcextend:tiny mcextend:musl"