aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2015-04-10 18:20:46 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-04-13 22:28:37 +0100
commitf4ad72e6e46e481d3fad920be9bb417fd175a991 (patch)
tree4d4e5b068cc22df847662ac8e3eed536a5ea4a88
parent92be71296e1b7ed1e6387ae381942072aa3bb4f3 (diff)
downloadopenembedded-core-contrib-f4ad72e6e46e481d3fad920be9bb417fd175a991.tar.gz
kbd: Mark glibc headers under __GLIBC__
Change-Id: I4e91038ea8b05defbb9d574c61eea96ccc064e51 Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/kbd/kbd/0003-Only-inluclude-kernel-headers-with-glibc.patch29
-rw-r--r--meta/recipes-core/kbd/kbd_2.0.2.bb1
2 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-core/kbd/kbd/0003-Only-inluclude-kernel-headers-with-glibc.patch b/meta/recipes-core/kbd/kbd/0003-Only-inluclude-kernel-headers-with-glibc.patch
new file mode 100644
index 0000000000..8bfcb0c7af
--- /dev/null
+++ b/meta/recipes-core/kbd/kbd/0003-Only-inluclude-kernel-headers-with-glibc.patch
@@ -0,0 +1,29 @@
+From 3c5c7acc7ef874b919b26583d3892e21b907833f Mon Sep 17 00:00:00 2001
+From: Natanael Copa <ncopa@alpinelinux.org>
+Date: Wed, 20 Aug 2014 09:00:03 +0200
+Subject: [PATCH 3/4] Only inluclude kernel headers with glibc
+
+This fixes compile errors with musl libc
+
+Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
+Upstream-Status: Pending
+---
+ src/resizecons.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/resizecons.c b/src/resizecons.c
+index 5f84845..691dfcc 100644
+--- a/src/resizecons.c
++++ b/src/resizecons.c
+@@ -80,7 +80,7 @@
+ #include <sys/ioctl.h>
+ #if (__GNU_LIBRARY__ >= 6)
+ #include <sys/perm.h>
+-#else
++#elif defined(__GLIBC__)
+ #include <linux/types.h>
+ #include <linux/termios.h>
+ #endif
+--
+2.1.0
+
diff --git a/meta/recipes-core/kbd/kbd_2.0.2.bb b/meta/recipes-core/kbd/kbd_2.0.2.bb
index 0aa976a46b..136dc7ac0e 100644
--- a/meta/recipes-core/kbd/kbd_2.0.2.bb
+++ b/meta/recipes-core/kbd/kbd_2.0.2.bb
@@ -12,6 +12,7 @@ RCONFLICTS_${PN} = "console-tools"
SRC_URI = "${KERNELORG_MIRROR}/linux/utils/${BPN}/${BP}.tar.xz \
file://uclibc-stdarg.patch \
+ file://0003-Only-inluclude-kernel-headers-with-glibc.patch \
"
SRC_URI[md5sum] = "87475eb78b1d6e6ab06686dd323ad4ba"