aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArmin Kuster <akuster@mvista.com>2016-09-23 23:14:36 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-10-06 08:47:58 +0100
commitdf7e4fdba42e9fcb799e812f6706bd56967858d9 (patch)
tree57bd9948f754a475b9c273e3eb81c5b7696f0a76
parent963c69e1e8e9cefccccb59619cb07ee31f07ffa1 (diff)
downloadopenembedded-core-contrib-df7e4fdba42e9fcb799e812f6706bd56967858d9.tar.gz
openssl: Security fix CVE-2016-6303
affects openssl < 1.0.1i Signed-off-by: Armin Kuster <akuster@mvista.com>
-rw-r--r--meta/recipes-connectivity/openssl/openssl/CVE-2016-6303.patch36
-rw-r--r--meta/recipes-connectivity/openssl/openssl_1.0.2h.bb1
2 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/openssl/openssl/CVE-2016-6303.patch b/meta/recipes-connectivity/openssl/openssl/CVE-2016-6303.patch
new file mode 100644
index 0000000000..95bdec42f8
--- /dev/null
+++ b/meta/recipes-connectivity/openssl/openssl/CVE-2016-6303.patch
@@ -0,0 +1,36 @@
+From 1027ad4f34c30b8585592764b9a670ba36888269 Mon Sep 17 00:00:00 2001
+From: "Dr. Stephen Henson" <steve@openssl.org>
+Date: Fri, 19 Aug 2016 23:28:29 +0100
+Subject: [PATCH] Avoid overflow in MDC2_Update()
+
+Thanks to Shi Lei for reporting this issue.
+
+CVE-2016-6303
+
+Reviewed-by: Matt Caswell <matt@openssl.org>
+(cherry picked from commit 55d83bf7c10c7b205fffa23fa7c3977491e56c07)
+
+Upstream-Status: Backport
+CVE: CVE-2016-6303
+Signed-off-by: Armin Kuster <akuster@mvista.com>
+
+---
+ crypto/mdc2/mdc2dgst.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/crypto/mdc2/mdc2dgst.c b/crypto/mdc2/mdc2dgst.c
+index 6615cf8..2dce493 100644
+--- a/crypto/mdc2/mdc2dgst.c
++++ b/crypto/mdc2/mdc2dgst.c
+@@ -91,7 +91,7 @@ int MDC2_Update(MDC2_CTX *c, const unsigned char *in, size_t len)
+
+ i = c->num;
+ if (i != 0) {
+- if (i + len < MDC2_BLOCK) {
++ if (len < MDC2_BLOCK - i) {
+ /* partial block */
+ memcpy(&(c->data[i]), in, len);
+ c->num += (int)len;
+--
+2.7.4
+
diff --git a/meta/recipes-connectivity/openssl/openssl_1.0.2h.bb b/meta/recipes-connectivity/openssl/openssl_1.0.2h.bb
index c1bced0043..436b37c69c 100644
--- a/meta/recipes-connectivity/openssl/openssl_1.0.2h.bb
+++ b/meta/recipes-connectivity/openssl/openssl_1.0.2h.bb
@@ -46,6 +46,7 @@ SRC_URI += "file://configure-targets.patch \
file://CVE-2016-2181_p3.patch \
file://CVE-2016-2182.patch \
file://CVE-2016-6302.patch \
+ file://CVE-2016-6303.patch \
"
SRC_URI[md5sum] = "9392e65072ce4b614c1392eefc1f23d0"