aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorArmin Kuster <akuster@mvista.com>2016-09-19 19:48:42 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-09-23 23:21:43 +0100
commit628b9bfc91a6f73a5dfff7ade1819ea6a2db7cf0 (patch)
treea21fe462c06c6311793024d76c3afd4c162b03fe
parent6f25d966c41df5315d253859d9ebf231963bf671 (diff)
downloadopenembedded-core-contrib-628b9bfc91a6f73a5dfff7ade1819ea6a2db7cf0.tar.gz
qemu: Security fix CVE-2016-4439
affects qemu < 2.6.0 Signed-off-by: Armin Kuster <akuster@mvista.com>
-rw-r--r--meta/recipes-devtools/qemu/qemu/CVE-2016-4439.patch46
-rw-r--r--meta/recipes-devtools/qemu/qemu_2.4.0.bb1
2 files changed, 47 insertions, 0 deletions
diff --git a/meta/recipes-devtools/qemu/qemu/CVE-2016-4439.patch b/meta/recipes-devtools/qemu/qemu/CVE-2016-4439.patch
new file mode 100644
index 0000000000..5d3b9a92d5
--- /dev/null
+++ b/meta/recipes-devtools/qemu/qemu/CVE-2016-4439.patch
@@ -0,0 +1,46 @@
+From 0a5e3685ea10c578f8063ca0dbb009af45693d85 Mon Sep 17 00:00:00 2001
+From: Prasad J Pandit <pjp@fedoraproject.org>
+Date: Thu, 19 May 2016 16:09:30 +0530
+Subject: [PATCH] esp: check command buffer length before write(CVE-2016-4439)
+
+The 53C9X Fast SCSI Controller(FSC) comes with an internal 16-byte
+FIFO buffer. It is used to handle command and data transfer. While
+writing to this command buffer 's->cmdbuf[TI_BUFSZ=16]', a check
+was missing to validate input length. Add check to avoid OOB write
+access.
+
+Fixes CVE-2016-4439.
+
+Reported-by: Li Qiang <liqiang6-s@360.cn>
+Cc: qemu-stable@nongnu.org
+Signed-off-by: Prasad J Pandit <pjp@fedoraproject.org>
+Message-Id: <1463654371-11169-2-git-send-email-ppandit@redhat.com>
+Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
+(cherry picked from commit c98c6c105f66f05aa0b7c1d2a4a3f716450907ef)
+Signed-off-by: Michael Roth <mdroth@linux.vnet.ibm.com>
+
+Upstream-Status: Backport
+CVE: CVE-2016-4439
+Signed-off-by: Armin Kuster <akuster@mvista.com>
+
+---
+ hw/scsi/esp.c | 6 +++++-
+ 1 file changed, 5 insertions(+), 1 deletion(-)
+
+Index: qemu-2.4.0/hw/scsi/esp.c
+===================================================================
+--- qemu-2.4.0.orig/hw/scsi/esp.c
++++ qemu-2.4.0/hw/scsi/esp.c
+@@ -446,7 +446,11 @@ void esp_reg_write(ESPState *s, uint32_t
+ break;
+ case ESP_FIFO:
+ if (s->do_cmd) {
+- s->cmdbuf[s->cmdlen++] = val & 0xff;
++ if (s->cmdlen < TI_BUFSZ) {
++ s->cmdbuf[s->cmdlen++] = val & 0xff;
++ } else {
++ trace_esp_error_fifo_overrun();
++ }
+ } else if (s->ti_size == TI_BUFSZ - 1) {
+ trace_esp_error_fifo_overrun();
+ } else {
diff --git a/meta/recipes-devtools/qemu/qemu_2.4.0.bb b/meta/recipes-devtools/qemu/qemu_2.4.0.bb
index 85dd39eccb..4eb4bcce87 100644
--- a/meta/recipes-devtools/qemu/qemu_2.4.0.bb
+++ b/meta/recipes-devtools/qemu/qemu_2.4.0.bb
@@ -25,6 +25,7 @@ SRC_URI += "file://configure-fix-Darwin-target-detection.patch \
file://CVE-2016-3712_p2.patch \
file://CVE-2016-3712_p3.patch \
file://CVE-2016-3712_p4.patch \
+ file://CVE-2016-4439.patch \
"
SRC_URI_prepend = "http://wiki.qemu-project.org/download/${BP}.tar.bz2"
SRC_URI[md5sum] = "186ee8194140a484a455f8e3c74589f4"