aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrad Mouring <brad.mouring@ni.com>2016-03-25 21:20:05 -0500
committerJoshua Lock <joshua.g.lock@intel.com>2016-05-06 15:51:14 +0100
commit37f074eed40ec0e100066eeef16ff8af555e3301 (patch)
treed677e0cd13f8b8eb8a244a216ec158118a7a5dc1
parentd9ea863ff844ee1b84d4699b0d3af7245f3703c5 (diff)
downloadopenembedded-core-contrib-37f074eed40ec0e100066eeef16ff8af555e3301.tar.gz
busybox: Backport patch to fix zcip false-conflict
Busybox upstream fixed the issue where an incorrect comparison of addresses led to bogus renegotiation of a new ll ip in 1.24. Backport this change to 1.23.1. Signed-off-by: Brad Mouring <brad.mouring@ni.com> Signed-off-by: Joshua Lock <joshua.g.lock@intel.com>
-rw-r--r--meta/recipes-core/busybox/busybox/0001-zcip-fix-wrong-comparison-of-source-IP-with-our-IP.patch34
-rw-r--r--meta/recipes-core/busybox/busybox_1.23.1.bb1
2 files changed, 35 insertions, 0 deletions
diff --git a/meta/recipes-core/busybox/busybox/0001-zcip-fix-wrong-comparison-of-source-IP-with-our-IP.patch b/meta/recipes-core/busybox/busybox/0001-zcip-fix-wrong-comparison-of-source-IP-with-our-IP.patch
new file mode 100644
index 0000000000..83bd114e31
--- /dev/null
+++ b/meta/recipes-core/busybox/busybox/0001-zcip-fix-wrong-comparison-of-source-IP-with-our-IP.patch
@@ -0,0 +1,34 @@
+From 4d15068d83054a9f82b3f8842706cd6deb401e25 Mon Sep 17 00:00:00 2001
+From: Vladislav Grishenko <themiron@mail.ru>
+Date: Thu, 19 Mar 2015 16:19:35 +0500
+Subject: [PATCH] zcip: fix wrong comparison of source IP with our IP
+
+Commit "zcip: fix link-local IP conflict detection" has introduced
+wrong comparsion of source IP with our IP. This leads to a new IP
+being picked unnecessarily on every incoming ARP packet.
+
+Signed-off-by: Vladislav Grishenko <themiron@mail.ru>
+Signed-off-by: Denys Vlasenko <vda.linux@googlemail.com>
+Signed-off-by: Brad Mouring <brad.mouring@ni.com>
+
+Upstream-Status: Backport (4d15068, added in 1.24)
+---
+ networking/zcip.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/networking/zcip.c b/networking/zcip.c
+index a3307c5..962ba2e 100644
+--- a/networking/zcip.c
++++ b/networking/zcip.c
+@@ -521,7 +521,7 @@ int zcip_main(int argc UNUSED_PARAM, char **argv)
+ target_ip_conflict = 0;
+
+ if (memcmp(&p.arp.arp_sha, &eth_addr, ETH_ALEN) != 0) {
+- if (memcmp(p.arp.arp_spa, &ip.s_addr, sizeof(struct in_addr))) {
++ if (memcmp(p.arp.arp_spa, &ip.s_addr, sizeof(struct in_addr)) == 0) {
+ /* A probe or reply with source_ip == chosen ip */
+ source_ip_conflict = 1;
+ }
+--
+2.7.3
+
diff --git a/meta/recipes-core/busybox/busybox_1.23.1.bb b/meta/recipes-core/busybox/busybox_1.23.1.bb
index 7c3ed84394..2360fa9a96 100644
--- a/meta/recipes-core/busybox/busybox_1.23.1.bb
+++ b/meta/recipes-core/busybox/busybox_1.23.1.bb
@@ -30,6 +30,7 @@ SRC_URI = "http://www.busybox.net/downloads/busybox-${PV}.tar.bz2;name=tarball \
file://login-utilities.cfg \
file://recognize_connmand.patch \
file://busybox-cross-menuconfig.patch \
+ file://0001-zcip-fix-wrong-comparison-of-source-IP-with-our-IP.patch \
"
SRC_URI[tarball.md5sum] = "5c94d6301a964cd91619bd4d74605245"