aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorVyacheslav Yurkov <uvv.mail@gmail.com>2021-01-28 19:42:46 +0100
committerSteve Sakoman <steve@sakoman.com>2021-02-04 04:57:53 -1000
commit1a0ac4d51bdc502ff56a7b57b3a9e72b25ccd7ae (patch)
treead4123fdcbd68f04ec991e2bb3de690e63667cca
parent6b5ff13fcbcfe980b50893a8bfe86ebf7a4ef3bf (diff)
downloadopenembedded-core-contrib-1a0ac4d51bdc502ff56a7b57b3a9e72b25ccd7ae.tar.gz
openembedded-core-contrib-1a0ac4d51bdc502ff56a7b57b3a9e72b25ccd7ae.tar.bz2
openembedded-core-contrib-1a0ac4d51bdc502ff56a7b57b3a9e72b25ccd7ae.zip
npm.bbclass: use python3 for npm config
python2-native executable is not available in sysroot anymore, which causes compilation of some nodejs modules to fail. Switch to python3 as a default python version. Signed-off-by: Vyacheslav Yurkov <uvv.mail@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit d21f50ecf8e8683a92b7d234fa8225c2c1470595) Signed-off-by: Steve Sakoman <steve@sakoman.com>
-rw-r--r--meta/classes/npm.bbclass6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/classes/npm.bbclass b/meta/classes/npm.bbclass
index 068032a1e57..f83c6e496e8 100644
--- a/meta/classes/npm.bbclass
+++ b/meta/classes/npm.bbclass
@@ -17,6 +17,8 @@
# NPM_INSTALL_DEV:
# Set to 1 to also install devDependencies.
+inherit python3native
+
DEPENDS_prepend = "nodejs-native "
RDEPENDS_${PN}_prepend = "nodejs "
@@ -237,9 +239,7 @@ python npm_do_compile() {
sysroot = d.getVar("RECIPE_SYSROOT_NATIVE")
nodedir = os.path.join(sysroot, d.getVar("prefix_native").strip("/"))
configs.append(("nodedir", nodedir))
- bindir = os.path.join(sysroot, d.getVar("bindir_native").strip("/"))
- pythondir = os.path.join(bindir, "python-native", "python")
- configs.append(("python", pythondir))
+ configs.append(("python", d.getVar("PYTHON")))
# Add node-pre-gyp configuration
args.append(("target_arch", d.getVar("NPM_ARCH")))