summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2020-04-17 18:15:27 +0800
committerSteve Sakoman <steve@sakoman.com>2020-04-30 11:59:59 -1000
commitb2a3cf79cf564a76727bd7dbb21ba9b3d20cf5d4 (patch)
tree1bed2a1e2631b1e6f20bcb5ff84fa44ff7adf6a1
parent81bec2f08229723b550a0cc33d1c77f82432814d (diff)
downloadopenembedded-core-contrib-b2a3cf79cf564a76727bd7dbb21ba9b3d20cf5d4.tar.gz
alsa-state: ignore 'No soundcards found' error in pkg_postinst
If there is no soundcards on the target (e.g. qemu), the pkp_postinst function will report an error: alsactl: load_state:1735: No soundcards found... pkg_run_script: package "alsa-state" postinst script returned status 19. opkg_configure: alsa-state.postinst returned 19. Pass '-g' option to alsactl to ignore this error. Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Steve Sakoman <steve@sakoman.com>
-rw-r--r--meta/recipes-bsp/alsa-state/alsa-state.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-bsp/alsa-state/alsa-state.bb b/meta/recipes-bsp/alsa-state/alsa-state.bb
index 0670556999..cec2272c80 100644
--- a/meta/recipes-bsp/alsa-state/alsa-state.bb
+++ b/meta/recipes-bsp/alsa-state/alsa-state.bb
@@ -62,7 +62,7 @@ pkg_postinst_${PN}() {
then
if test -x ${sbindir}/alsactl
then
- ${sbindir}/alsactl -f ${localstatedir}/lib/alsa/asound.state restore
+ ${sbindir}/alsactl -g -f ${localstatedir}/lib/alsa/asound.state restore
fi
fi
}