summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-04-14 10:31:53 -0700
committerSteve Sakoman <steve@sakoman.com>2020-04-30 11:59:59 -1000
commita2b1af47316a9f5c522db0c9feff1fbe0d39e022 (patch)
treeb40f44b55e5809831eb835389bd3bb4a9183bb97
parent5dbb7d5bb9509dd455673a326c9191dec6f3092c (diff)
downloadopenembedded-core-contrib-a2b1af47316a9f5c522db0c9feff1fbe0d39e022.tar.gz
ruby: Link with libucontext on musl
coroutines in ruby 2.7+ needs ucontext APIs which are not available in musl but an external library is available to provide them so use it Use cached values for ac_cv_func_isnan and ac_cv_func_isinf this is not detected correctly by configure on musl on ARM drop using old arm32 implementation of coroutine which is slow and inefficient Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> Signed-off-by: Steve Sakoman <steve@sakoman.com>
-rw-r--r--meta/recipes-devtools/ruby/ruby_2.7.0.bb9
1 files changed, 7 insertions, 2 deletions
diff --git a/meta/recipes-devtools/ruby/ruby_2.7.0.bb b/meta/recipes-devtools/ruby/ruby_2.7.0.bb
index 44c76161d5..7f07080497 100644
--- a/meta/recipes-devtools/ruby/ruby_2.7.0.bb
+++ b/meta/recipes-devtools/ruby/ruby_2.7.0.bb
@@ -1,5 +1,7 @@
require ruby.inc
+DEPENDS_append_libc-musl = " libucontext"
+
SRC_URI += " \
file://remove_has_include_macros.patch \
file://run-ptest \
@@ -25,8 +27,11 @@ EXTRA_OECONF = "\
--with-pkg-config=pkg-config \
"
-EXTRA_OECONF_append_libc-musl_arm = " --with-coroutine=arm32"
-EXTRA_OECONF_append_libc-musl_armeb = " --with-coroutine=arm32"
+EXTRA_OECONF_append_libc-musl = "\
+ LIBS='-lucontext' \
+ ac_cv_func_isnan=yes \
+ ac_cv_func_isinf=yes \
+"
do_install() {
oe_runmake 'DESTDIR=${D}' install