summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJon Mason <jdmason@kudzu.us>2021-09-16 18:19:32 -0400
committerSteve Sakoman <steve@sakoman.com>2021-09-24 04:27:46 -1000
commit4b4131f28dd4d0f61d92d0c0bb0e058a755f65b6 (patch)
tree157dc679b8b0d4f8f51381ddb1ee64ed5d3fa785
parent0e61fb4f00b1024a96c18f33825110a426a4f984 (diff)
downloadopenembedded-core-contrib-4b4131f28dd4d0f61d92d0c0bb0e058a755f65b6.tar.gz
core-image-sato: Fix runqemu error for qemuarmv5
When attempting to execute runqemu on qemuarmv5, the following error is encountered: runqemu - ERROR - Failed to run qemu: qemu-system-arm: versatilepb: memory size must not exceed 256MB To work around this, limit the QB_MEM size for qemuarmv5, similar to what is being done for qemumips. Signed-off-by: Jon Mason <jdmason@kudzu.us> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit 6450138afebffcc55ab32afadd5fb979274fff2b) Signed-off-by: Steve Sakoman <steve@sakoman.com>
-rw-r--r--meta/recipes-sato/images/core-image-sato.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta/recipes-sato/images/core-image-sato.bb b/meta/recipes-sato/images/core-image-sato.bb
index e50b24a476..300d8e0d43 100644
--- a/meta/recipes-sato/images/core-image-sato.bb
+++ b/meta/recipes-sato/images/core-image-sato.bb
@@ -13,4 +13,5 @@ TOOLCHAIN_HOST_TASK_append = " nativesdk-intltool nativesdk-glib-2.0"
TOOLCHAIN_HOST_TASK_remove_task-populate-sdk-ext = " nativesdk-intltool nativesdk-glib-2.0"
QB_MEM = '${@bb.utils.contains("DISTRO_FEATURES", "opengl", "-m 512", "-m 256", d)}'
+QB_MEM_qemuarmv5 = "-m 256"
QB_MEM_qemumips = "-m 256"