summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2020-10-01 16:50:25 +0100
committerSteve Sakoman <steve@sakoman.com>2020-10-07 13:33:58 -1000
commit275d504b2f979901278141a4ba217d02a099f980 (patch)
tree339baf4fe45de68a8325064d058f006c3a4fcc54
parent7325222ce0dc8a75bc2d3eb7b6049f0d995ce17f (diff)
downloadopenembedded-core-contrib-275d504b2f979901278141a4ba217d02a099f980.tar.gz
libtools-cross/shadow-sysroot: Use nopackages inherit
When testing pseudo changes I realised these recipes have packaging tasks but don't generate packages. Drop the packages tasks for cleanliness. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> (cherry picked from commit ef9c11797b5d626bdb40b4509d8b2b0d461ff9ea) Signed-off-by: Steve Sakoman <steve@sakoman.com>
-rw-r--r--meta/recipes-devtools/libtool/libtool-cross_2.4.6.bb2
-rw-r--r--meta/recipes-extended/shadow/shadow-sysroot_4.6.bb2
2 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-devtools/libtool/libtool-cross_2.4.6.bb b/meta/recipes-devtools/libtool/libtool-cross_2.4.6.bb
index 522bf3a0e9..02c6e152fc 100644
--- a/meta/recipes-devtools/libtool/libtool-cross_2.4.6.bb
+++ b/meta/recipes-devtools/libtool/libtool-cross_2.4.6.bb
@@ -6,6 +6,8 @@ SRC_URI += "file://fixinstall.patch"
datadir = "${STAGING_DIR_TARGET}${target_datadir}"
+inherit nopackages
+
do_configure_prepend () {
# Remove any existing libtool m4 since old stale versions would break
# any upgrade
diff --git a/meta/recipes-extended/shadow/shadow-sysroot_4.6.bb b/meta/recipes-extended/shadow/shadow-sysroot_4.6.bb
index 79fc8b80b5..5f7ea00bf1 100644
--- a/meta/recipes-extended/shadow/shadow-sysroot_4.6.bb
+++ b/meta/recipes-extended/shadow/shadow-sysroot_4.6.bb
@@ -30,3 +30,5 @@ SYSROOT_DIRS += "${sysconfdir}"
# otherwise: dbus-dev depends on shadow-sysroot-dev which depends on shadow-sysroot
# and this has another copy of /etc/login.defs already provided by shadow
PACKAGES = ""
+
+inherit nopackages