summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-01-08 14:27:55 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-01-10 20:32:04 +0000
commitc4fdb3a8629c0c230e430a60df850f9c5ed4a423 (patch)
treeb26ad7c912e6d2840269331c311cf8c3b39b1752
parent9863bb29f481023081b30a55d3304afe1d7b6e8b (diff)
downloadopenembedded-core-contrib-c4fdb3a8629c0c230e430a60df850f9c5ed4a423.tar.gz
gawk: fix failing ptests
They were failing due to incorrect locale being used. Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-extended/gawk/gawk_5.0.1.bb2
1 files changed, 2 insertions, 0 deletions
diff --git a/meta/recipes-extended/gawk/gawk_5.0.1.bb b/meta/recipes-extended/gawk/gawk_5.0.1.bb
index eaba6c78ed..e79ccfdebf 100644
--- a/meta/recipes-extended/gawk/gawk_5.0.1.bb
+++ b/meta/recipes-extended/gawk/gawk_5.0.1.bb
@@ -46,6 +46,8 @@ do_install_ptest() {
done
sed -i -e 's|/usr/local/bin|${bindir}|g' \
-e 's|#!${base_bindir}/awk|#!${bindir}/awk|g' ${D}${PTEST_PATH}/test/*.awk
+
+ sed -i -e "s|GAWKLOCALE|LANG|g" ${D}${PTEST_PATH}/test/Maketests
}
RDEPENDS_${PN}-ptest += "make"