summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2020-01-10 17:24:21 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-01-11 09:17:20 +0000
commit7e0f6c9ea4f824f29dc30c6631fd8039ebe83a0b (patch)
tree715606c795ee06cd3c3bb729834be26d668ec640
parent9e7b38c61c6b84b7f137c733ac5da9414025693d (diff)
downloadopenembedded-core-contrib-7e0f6c9ea4f824f29dc30c6631fd8039ebe83a0b.tar.gz
perl: improve reproducibility
Occasionally the reproducibility selftest fails because perl-pod differs, specifically that the perltoc.pod file was sometimes missing modules. Debugging revealed that there are missing dependencies so there is a build race: building perltoc.pod from an clean build tree results in no modules being listed at all. A bug has been filed at https://github.com/arsv/perl-cross/issues/86 to solve this properly, but for now we can just delete perltoc.pod after make has finished and re-generate it. [ YOCTO #13726 ] Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/perl/perl_5.30.1.bb8
1 files changed, 8 insertions, 0 deletions
diff --git a/meta/recipes-devtools/perl/perl_5.30.1.bb b/meta/recipes-devtools/perl/perl_5.30.1.bb
index 66707e7f9d..03e7f206f9 100644
--- a/meta/recipes-devtools/perl/perl_5.30.1.bb
+++ b/meta/recipes-devtools/perl/perl_5.30.1.bb
@@ -112,6 +112,14 @@ print(datetime.fromtimestamp($SOURCE_DATE_EPOCH, timezone.utc).strftime('%a %b %
do_compile() {
oe_runmake
+ # This isn't generated reliably so delete and re-generate.
+ # https://github.com/arsv/perl-cross/issues/86
+
+ if [ -e pod/perltoc.pod ]; then
+ bbnote Rebuilding perltoc.pod
+ rm -f pod/perltoc.pod
+ oe_runmake pod/perltoc.pod
+ fi
}
do_install() {