summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Orling <ticotimo@gmail.com>2024-02-15 14:04:55 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2024-02-16 15:13:15 +0000
commit651fc15e1403268aca19bd1453b3796d1effa559 (patch)
tree772aa6a4803abc50cbfd1f4b64e4a36faaeafb51
parent5b290566519a87c563945a033cb49863317ad63d (diff)
downloadopenembedded-core-contrib-651fc15e1403268aca19bd1453b3796d1effa559.tar.gz
python3-poetry-core: upgrade 1.8.1 -> 1.9.0
This version deprecates "poetry.core.masonry.builder", but we detect "poetry.core.masonry.api" in recipetool and nothing has broken our build of wheels. Thanks to Ross for noticing that the "from poetry.core.masonry.builders.wheel import WheelBuilder" is not a massive change in practice. Changes: 1.9.0 - 2024-02-02 Added * Add a to key in tool.poetry.packages to allow custom subpackage names (#672). * Add support for path dependencies that do not define a build system (#675). * Add a tool.poetry.package-mode key to support non-package mode (#661). Changed * Update list of supported licenses (#659, #669, #678, #694). * Improve support for PEP 691 JSON-based Simple API (#664). * Establish zipapp compatibility (#670). * Rework list of files included in build artifacts (#666). * Improve performance by treating collections in packages as immutable (#663). * Deprecate poetry.core.masonry.builder (#682). * Deprecate scripts that depend on extras (#690). Fixed * Fix an issue where insignificant errors were printed if the working directory is not inside a git repository (#684). * Fix an issue where the project's directory was not recognized as git repository on Windows due to an encoding issue (#685). Vendoring * fastjsonschema==2.19.1 * lark==1.1.8 https://github.com/python-poetry/poetry-core/blob/main/CHANGELOG.md#190---2024-02-02 Signed-off-by: Tim Orling <tim.orling@konsulko.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/python/python3-poetry-core_1.9.0.bb (renamed from meta/recipes-devtools/python/python3-poetry-core_1.8.1.bb)2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python3-poetry-core_1.8.1.bb b/meta/recipes-devtools/python/python3-poetry-core_1.9.0.bb
index fcb6d30ee0..dfb29c4b86 100644
--- a/meta/recipes-devtools/python/python3-poetry-core_1.8.1.bb
+++ b/meta/recipes-devtools/python/python3-poetry-core_1.9.0.bb
@@ -15,7 +15,7 @@ LIC_FILES_CHKSUM = "\
file://src/poetry/core/_vendor/tomli/LICENSE;md5=aaaaf0879d17df0110d1aa8c8c9f46f5 \
"
-SRC_URI[sha256sum] = "67a76c671da2a70e55047cddda83566035b701f7e463b32a2abfeac6e2a16376"
+SRC_URI[sha256sum] = "fa7a4001eae8aa572ee84f35feb510b321bd652e5cf9293249d62853e1f935a2"
inherit python_poetry_core pypi
PYPI_ARCHIVE_NAME = "poetry_core-${PV}.${PYPI_PACKAGE_EXT}"