aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-09-03 14:45:37 +0100
committerSaul Wold <sgw@linux.intel.com>2012-09-03 22:52:54 -0700
commit971fbbd50ae147805fc7498b72a046be5bffc3c7 (patch)
treeeace5c1b5bb9274577e3c9b7e6a97d0ed5fff5f3
parent4d29ef0fa885299392779042830b95176e31fe11 (diff)
downloadopenembedded-core-contrib-971fbbd50ae147805fc7498b72a046be5bffc3c7.tar.gz
oprofileui: split server to separate recipe to avoid X11 dependency
Increase SRCREV to include an upstream patch that fixes the configure script so that the server can be built separately without gtk+ and avahi-ui, and create a separate recipe for the server. Also fix the RDEPENDS so that oprofile actually gets pulled in by the client and the server. Part of the fix for [YOCTO #1690]. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
-rw-r--r--meta/recipes-kernel/oprofile/oprofileui-server_git.bb13
-rw-r--r--meta/recipes-kernel/oprofile/oprofileui.inc11
-rw-r--r--meta/recipes-kernel/oprofile/oprofileui_git.bb10
3 files changed, 24 insertions, 10 deletions
diff --git a/meta/recipes-kernel/oprofile/oprofileui-server_git.bb b/meta/recipes-kernel/oprofile/oprofileui-server_git.bb
new file mode 100644
index 0000000000..b9f6a811e5
--- /dev/null
+++ b/meta/recipes-kernel/oprofile/oprofileui-server_git.bb
@@ -0,0 +1,13 @@
+require oprofileui.inc
+
+SRCREV = "82ecf8c6b53b84f80682a8312f9defa83a95f2a3"
+PV = "0.0+git${SRCPV}"
+PR = "r0"
+
+S = "${WORKDIR}/git"
+
+SRC_URI = "git://git.yoctoproject.org/oprofileui;protocol=git"
+
+EXTRA_OECONF += "--disable-client --enable-server"
+
+RDEPENDS_${PN} = "oprofile"
diff --git a/meta/recipes-kernel/oprofile/oprofileui.inc b/meta/recipes-kernel/oprofile/oprofileui.inc
index ab14c38e33..9a9bc198b0 100644
--- a/meta/recipes-kernel/oprofile/oprofileui.inc
+++ b/meta/recipes-kernel/oprofile/oprofileui.inc
@@ -8,16 +8,9 @@ SECTION = "x11"
LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f"
-DEPENDS = "glib-2.0 gtk+ libglade libxml2 avahi-ui gconf"
+DEPENDS = "glib-2.0 avahi"
-inherit autotools pkgconfig gtk-icon-cache
-
-PACKAGES =+ "oprofileui-server oprofileui-viewer"
+inherit autotools pkgconfig
EXTRA_OECONF = "--with-avahi"
-FILES_oprofileui-viewer = "${bindir}/oparchconv ${bindir}/oprofile-viewer ${datadir}/applications/ ${datadir}/oprofileui/"
-RDEPENDS_oprofile-viewer = "oprofile"
-
-FILES_oprofileui-server = "${bindir}/oprofile-server"
-RDEPENDS_oprofile-server = "oprofile"
diff --git a/meta/recipes-kernel/oprofile/oprofileui_git.bb b/meta/recipes-kernel/oprofile/oprofileui_git.bb
index 3fe9bb4e6a..2c6e96a85e 100644
--- a/meta/recipes-kernel/oprofile/oprofileui_git.bb
+++ b/meta/recipes-kernel/oprofile/oprofileui_git.bb
@@ -1,10 +1,18 @@
require oprofileui.inc
+DEPENDS += "gtk+ libglade libxml2 avahi-ui gconf"
+
SRCREV = "82ecf8c6b53b84f80682a8312f9defa83a95f2a3"
PV = "0.0+git${SRCPV}"
PR = "r0"
S = "${WORKDIR}/git"
-# Oprofileui at http://labs.o-hand.com/oprofileui/ is not maintained now.
SRC_URI = "git://git.yoctoproject.org/oprofileui;protocol=git"
+
+EXTRA_OECONF += "--enable-client --disable-server"
+
+PACKAGES =+ "oprofileui-viewer"
+
+FILES_oprofileui-viewer = "${bindir}/oparchconv ${bindir}/oprofile-viewer ${datadir}/applications/ ${datadir}/oprofileui/"
+RDEPENDS_oprofileui-viewer = "oprofile"