aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCristian Iorga <cristian.iorga@intel.com>2012-11-21 21:54:24 +0200
committerMarcin Juszkiewicz <marcin.juszkiewicz@linaro.org>2012-11-29 12:00:36 +0100
commit7e5a188f8f3cddda54e0a46ebc3bd852655db90c (patch)
treef0bd94c1fdd9971763456d7a76f9e4070f16d964
parentf6fcc0b73779f1fb3be28306b3616ae180734f72 (diff)
downloadopenembedded-core-contrib-7e5a188f8f3cddda54e0a46ebc3bd852655db90c.tar.gz
builder: fix adduser breakage with password
Build Appliance needs to have for the builder user a password set. However, the useradd.bbclass requires the last parameter to be the user's group name. Previously, the password was the last parameter to useradd command. Fixed using the right order for parameters. Signed-off-by: Cristian Iorga <cristian.iorga@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-graphics/builder/builder_0.1.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/meta/recipes-graphics/builder/builder_0.1.bb b/meta/recipes-graphics/builder/builder_0.1.bb
index 41871d6f1b..78d41e578d 100644
--- a/meta/recipes-graphics/builder/builder_0.1.bb
+++ b/meta/recipes-graphics/builder/builder_0.1.bb
@@ -1,7 +1,7 @@
SUMMARY = "New user to do specific job"
DESCRIPTION = "This recipe create a new user named ${PN}, who is used for specific jobs like building. The task can be auto started via mini X"
SECTION = "x11"
-PR = "r5"
+PR = "r6"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://builder_hob_start.sh;endline=5;md5=84796c3c41785d86100fdabcbdade00e"
@@ -20,8 +20,8 @@ BUILDER_PASSWORD ?= ".gLibiNXn0P12"
USERADD_PACKAGES = "${PN}"
USERADD_PARAM_${PN} = "--system --create-home \
--groups video,tty,audio \
- --user-group ${PN} \
- --password ${BUILDER_PASSWORD}"
+ --password ${BUILDER_PASSWORD} \
+ --user-group ${PN}"
do_install () {
install -d -m 755 ${D}${sysconfdir}/mini_x/session.d