aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-01-08 10:47:06 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2011-01-08 10:55:59 +0100
commit234596fc5d169b91aba8f998e20307715fdebfcc (patch)
treeb29fb8d407ed2548c867df2b626556e40e11b16c
parent7173560f284e57c0160a12e0f46e2f9224da5be2 (diff)
downloadopenembedded-core-contrib-234596fc5d169b91aba8f998e20307715fdebfcc.tar.gz
TI BSP: add support the AM37x EVM board
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
-rw-r--r--conf/machine/am37x-evm.conf51
-rw-r--r--recipes-bsp/u-boot/u-boot_git.bb7
2 files changed, 58 insertions, 0 deletions
diff --git a/conf/machine/am37x-evm.conf b/conf/machine/am37x-evm.conf
new file mode 100644
index 0000000000..0b9e2ddce1
--- /dev/null
+++ b/conf/machine/am37x-evm.conf
@@ -0,0 +1,51 @@
+#@TYPE: Machine
+#@NAME: AM37x EVM
+#@DESCRIPTION: Machine configuration for the TI AM37x EVM
+TARGET_ARCH = "arm"
+
+PREFERRED_PROVIDER_virtual/xserver = "xserver-xorg"
+XSERVER = "xserver-xorg \
+ xf86-input-evdev \
+ xf86-input-mouse \
+ xf86-input-tslib \
+ xf86-video-omapfb \
+ xf86-input-keyboard"
+
+GUI_MACHINE_CLASS = "smallscreen"
+
+require conf/machine/include/omap3.inc
+
+# Ship all kernel modules
+
+IMAGE_FSTYPES ?= "jffs2 tar.bz2"
+EXTRA_IMAGECMD_jffs2 = "-lnp -e 0x20000 -s 2048"
+
+SERIAL_CONSOLE = "115200 ttyS0"
+
+PREFERRED_PROVIDER_virtual/kernel = "linux-omap-psp"
+
+PREFERRED_PROVIDER_virtual/bootloader = "u-boot"
+
+UBOOT_ARCH = "arm"
+UBOOT_MACHINE = "omap3_evm_config"
+XLOAD_MACHINE = "omap3evm_config"
+
+MACHINE_FEATURES = "kernel26 apm usbgadget usbhost vfat ext2 screen touchscreen"
+
+# NOTE: there are NAND and OneNAND versions of this board...
+
+# do ubiattach /dev/ubi_ctrl -m 4
+# From dmesg:
+# UBI: smallest flash I/O unit: 2048
+# UBI: logical eraseblock size: 129024 bytes
+# from ubiattach stdout:
+# UBI device number 0, total 1996 LEBs
+MKUBIFS_ARGS = "-m 2048 -e 129024 -c 1996"
+
+# do ubiattach /dev/ubi_ctrl -m 4
+# from dmesg:
+# UBI: smallest flash I/O unit: 2048
+# UBI: physical eraseblock size: 131072 bytes (128 KiB)
+# UBI: sub-page size: 512
+UBINIZE_ARGS = "-m 2048 -p 128KiB -s 512"
+
diff --git a/recipes-bsp/u-boot/u-boot_git.bb b/recipes-bsp/u-boot/u-boot_git.bb
index 5546447dac..f7423c951b 100644
--- a/recipes-bsp/u-boot/u-boot_git.bb
+++ b/recipes-bsp/u-boot/u-boot_git.bb
@@ -66,6 +66,13 @@ SRC_URI_omap3evm = "git://arago-project.org/git/projects/u-boot-omap3.git;protoc
SRCREV_omap3evm = "c0a8fb217fdca7888d89f9a3dee74a4cec865620"
PV_omap3evm = "2009.11+${PR}+gitr${SRCREV}"
+# ~ TI PSP v2009.11_OMAPPSP_03.00.01.06 (+ couple of commits)
+SRC_URI_am37x-evm = "git://arago-project.org/git/projects/u-boot-omap3.git;protocol=git \
+ file://0001-omap3evm-Change-default-console-serial-port-from.patch \
+"
+SRCREV_am37x-evm = "c0a8fb217fdca7888d89f9a3dee74a4cec865620"
+PV_am37x-evm = "2009.11+${PR}+gitr${SRCREV}"
+
# hawkboard - master branch (hawk still .07beta)
SRC_URI_hawkboard = "git://arago-project.org/git/people/sekhar/u-boot-omapl1.git;protocol=git;branch=master"
SRC_URI_hawkboard += "file://dont-inline-weak-symbols.patch"