aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorScott Ellis <scott@jumpnowtek.com>2016-01-18 05:42:48 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-19 17:37:34 +0000
commita4b48c26c5c011f8568537fa63521106067ab0c2 (patch)
tree3083460a2d9b5c3f0b22753e2b5fc9115d741edf
parent7a0b1c185083806500492cf87e823dd6c4b1795e (diff)
downloadopenembedded-core-contrib-a4b48c26c5c011f8568537fa63521106067ab0c2.tar.gz
coreutils: Add xattr PACKAGECONFIG
From Yocto poky where it also stops this warning WARNING: QA Issue: coreutils rdepends on libattr, but it isn't a build dependency? [build-deps] (From OE-Core rev: 025c348d0f12be9405a8d14e9ef6787e37ee7a23) Signed-off-by: Scott Ellis <scott@jumpnowtek.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-core/coreutils/coreutils_8.24.bb9
1 files changed, 7 insertions, 2 deletions
diff --git a/meta/recipes-core/coreutils/coreutils_8.24.bb b/meta/recipes-core/coreutils/coreutils_8.24.bb
index f042346241..6a09c594dc 100644
--- a/meta/recipes-core/coreutils/coreutils_8.24.bb
+++ b/meta/recipes-core/coreutils/coreutils_8.24.bb
@@ -28,14 +28,19 @@ SRC_URI[manpages.sha256sum] = "cf0333b5f134a331e0b46e2ddf90666f8bdc3281c1ca2c7cc
EXTRA_OECONF_class-native = "--without-gmp"
EXTRA_OECONF_class-target = "--enable-install-program=arch --libexecdir=${libdir}"
-# acl is not a default feature
+# acl and xattr are not default features
#
-PACKAGECONFIG_class-target ??= "${@bb.utils.contains('DISTRO_FEATURES', 'acl', 'acl', '', d)}"
+PACKAGECONFIG_class-target ??= "\
+ ${@bb.utils.contains('DISTRO_FEATURES', 'acl', 'acl', '', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'xattr', 'xattr', '', d)} \
+"
+
PACKAGECONFIG_class-native ??= ""
# with, without, depends, rdepends
#
PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,acl,"
+PACKAGECONFIG[xattr] = "--enable-xattr,--disable-xattr,attr,"
# [ df mktemp base64 gets a special treatment and is not included in this
bindir_progs = "arch basename chcon cksum comm csplit cut dir dircolors dirname du \