aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOlof Johansson <olof.johansson@axis.com>2016-01-19 14:45:32 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-01-19 17:40:20 +0000
commit0916235adf36f5c7d3d4b2f613ef9ff8b690f983 (patch)
tree721c9d203dec02b456b9e5ed073422f132711072
parent2dbd61f242299de2c687a3042656b3a8c3553a04 (diff)
downloadopenembedded-core-contrib-0916235adf36f5c7d3d4b2f613ef9ff8b690f983.tar.gz
rpm: remove bashisms: [ x == x ] -> [ x = x ]
The postinst and postrm of rpm contained a bashism, that could in some situations potentially cause ldconfig not be triggered when it should be. If you use dash on host, test would fail because of syntax errors. But on host, it should fail because of the comparison. On target, you often use busybox ash, and it supports == as an alias for =. So in practice, only if you use a shell like dash on target, you'll run into issues with this. (From OE-Core rev: 4fd33ca846ba9f61e72a176a6462443c9fb5ddc2) Signed-off-by: Olof Johansson <olofjn@axis.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-devtools/rpm/rpm_4.11.2.bb5
1 files changed, 2 insertions, 3 deletions
diff --git a/meta/recipes-devtools/rpm/rpm_4.11.2.bb b/meta/recipes-devtools/rpm/rpm_4.11.2.bb
index a48852f875..3683971cd5 100644
--- a/meta/recipes-devtools/rpm/rpm_4.11.2.bb
+++ b/meta/recipes-devtools/rpm/rpm_4.11.2.bb
@@ -101,8 +101,7 @@ do_install_append() {
}
pkg_postinst_${PN}() {
-
- [ "x\$D" == "x" ] && ldconfig
+ [ "x\$D" = "x" ] && ldconfig
test -f ${localstatedir}/lib/rpm/Packages || rpm --initdb
rm -f ${localstatedir}/lib/rpm/Filemd5s \
${localstatedir}/lib/rpm/Filedigests \
@@ -112,7 +111,7 @@ pkg_postinst_${PN}() {
}
pkg_postrm_${PN}() {
- [ "x\$D" == "x" ] && ldconfig
+ [ "x\$D" = "x" ] && ldconfig
}