aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-04-19 13:56:00 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-04-19 21:11:24 +0100
commit9c8a049f48be5596e538013f3fb0d0dbd3eef2ec (patch)
tree34090610f3ba22d26e8b8b2259d31d25aa89713a
parent9de732481a5e77b4b17e0af108c78062b655a50a (diff)
downloadopenembedded-core-contrib-9c8a049f48be5596e538013f3fb0d0dbd3eef2ec.tar.gz
perf: pass DESTDIR in EXTRA_OEMAKE
Instead of passing DESTDIR just in the make install invocation, pass it in EXTRA_OEMAKE. This appears to stop perf from rebuilding at instal time for me, which appears to be the trigger for the random build failure. [ YOCTO #9182 ] (From OE-Core rev: 76c473dbe9e6a1eb8bca89f26cf29b41ca18d680) Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
-rw-r--r--meta/recipes-kernel/perf/perf.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-kernel/perf/perf.bb b/meta/recipes-kernel/perf/perf.bb
index c43f39cd1d..3d6ffb30fb 100644
--- a/meta/recipes-kernel/perf/perf.bb
+++ b/meta/recipes-kernel/perf/perf.bb
@@ -88,6 +88,7 @@ EXTRA_OEMAKE = '\
'
EXTRA_OEMAKE += "\
+ 'DESTDIR=${D}' \
'prefix=${prefix}' \
'bindir=${bindir}' \
'sharedir=${datadir}' \
@@ -110,7 +111,7 @@ do_compile() {
do_install() {
# Linux kernel build system is expected to do the right thing
unset CFLAGS
- oe_runmake DESTDIR=${D} install
+ oe_runmake install
# we are checking for this make target to be compatible with older perf versions
if [ "${@perf_feature_enabled('perf-scripting', 1, 0, d)}" = "1" ] && grep -q install-python_ext ${S}/tools/perf/Makefile*; then
oe_runmake DESTDIR=${D} install-python_ext